# CVE-2019-1010266: Regular Expression Denial of Service (ReDoS) in lodash

> An attacker can cause a denial of service by providing long strings that trigger excessive resource consumption in the Date handler.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2019
- **Updated:** 5 Aug 2024
- **Also known as:** AZL-45159, DEBIAN-CVE-2019-1010266, GHSA-x5rq-j2xg-h7qm, SNYK-JS-LODASH-73639, UBUNTU-CVE-2019-1010266

## What is CVE-2019-1010266?

CVE-2019-1010266 is a medium-severity denial of service vulnerability in lodash, published on 17 Jul 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

lodash prior to 4.17.11 is affected by: CWE-400: Uncontrolled Resource Consumption. The impact is: Denial of service. The component is: Date handler. The attack vector is: Attacker provides very long strings, which the library attempts to match using a regular expression. The fixed version is: 4.17.11.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2019-1010266?

8 open source packages ship an affected version, including lodash-rails, lodash and lodash-amd. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lodash-rails` | RubyGems | From 4.7.0 | 4.17.11 |
| `lodash-rails` | RubyGems | From 4.7.0 | 4.17.11 |
| `lodash` | npm | From 4.7.0 | 4.17.11 |
| `lodash` | npm | From 4.7.0 | 4.17.11 |
| `lodash-amd` | npm | From 4.7.0 | 4.17.11 |
| `lodash-amd` | npm | From 4.7.0 | 4.17.11 |
| `lodash-es` | npm | From 4.7.0 | 4.17.11 |
| `lodash-es` | npm | From 4.7.0 | 4.17.11 |

Products: Lodash Lodash.

## How do I fix CVE-2019-1010266?

Upgrade lodash-rails to 4.17.11 or later.

## Is CVE-2019-1010266 being exploited?

There is no known exploitation of CVE-2019-1010266 in the wild and no public exploit code.

## Other vulnerabilities in lodash

- [CVE-2026-4800](https://insights.sbomify.com/CVE-2026-4800/): lodash vulnerable to Code Injection via `_.template` imports key names (high 8.1)
- [CVE-2020-8203](https://insights.sbomify.com/CVE-2020-8203/): Prototype Pollution in lodash (high 7.4)
- [CVE-2021-23337](https://insights.sbomify.com/CVE-2021-23337/): Command Injection (high 7.2)
- [CVE-2025-13465](https://insights.sbomify.com/CVE-2025-13465/): Prototype Pollution Vulnerability in Lodash _.unset and _.omit functions (medium 6.9)
- [CVE-2026-2950](https://insights.sbomify.com/CVE-2026-2950/): lodash vulnerable to Prototype Pollution via array path bypass in `_.unset` and `_.omit` (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1010266 and fix it if it is affected.

What it is: CVE-2019-1010266 is a medium-severity denial of service vulnerability in lodash, published on 17 Jul 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-1010266 in the wild and no public exploit code.

Affected packages and fixed versions:
- lodash-rails (RubyGems): affected from 4.7.0; fixed in 4.17.11
- lodash-rails (RubyGems): affected from 4.7.0; fixed in 4.17.11
- lodash (npm): affected from 4.7.0; fixed in 4.17.11
- lodash (npm): affected from 4.7.0; fixed in 4.17.11
- lodash-amd (npm): affected from 4.7.0; fixed in 4.17.11
- lodash-amd (npm): affected from 4.7.0; fixed in 4.17.11
- lodash-es (npm): affected from 4.7.0; fixed in 4.17.11
- lodash-es (npm): affected from 4.7.0; fixed in 4.17.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1010266/ (Markdown: https://insights.sbomify.com/CVE-2019-1010266/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1010266
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1010266
- OSV: https://osv.dev/vulnerability/CVE-2019-1010266

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1010266/
Summaries are generated and may contain mistakes; the official description above is the record.
