# CVE-2019-1010268: Improper Restriction of XML External Entity Reference in ladon

> An attacker can exploit an XML External Entity vulnerability in Ladon's SOAP handlers to read local files and access internal network endpoints.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jul 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-vg35-vc9f-q7x2, PYSEC-2019-184

## What is CVE-2019-1010268?

CVE-2019-1010268 is a critical vulnerability in Ladon, published on 18 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Ladon since 0.6.1 (since ebef0aae48af78c159b6fce81bc6f5e7e0ddb059) is affected by: XML External Entity (XXE). The impact is: Information Disclosure, reading files and reaching internal network endpoints. The component is: SOAP request handlers. For instance: https://bitbucket.org/jakobsg/ladon/src/42944fc012a3a48214791c120ee5619434505067/src/ladon/interfaces/soap.py#lines-688. The attack vector is: Send a specially crafted SOAP call.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2019-1010268?

3 open source packages ship an affected version, including ladon. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ladon` | PyPI | From 0.6.1 to 1.0.7 | None |
| `ladon` | PyPI | From 0.6.1 to 1.0.7 | None |
| `ladon` | PyPI | From 0.6.1 | 1.0.0 |

Products: Ladon Project Ladon.

## How do I fix CVE-2019-1010268?

Upgrade ladon to 1.0.0 or later.

## Is CVE-2019-1010268 being exploited?

There is no known exploitation of CVE-2019-1010268 in the wild and no public exploit code.

Public exploit code:

- Python exploit written for CVE-2019-1010268. (github_poc): https://github.com/Tonyynot14/CVE-2019-1010268

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1010268 and fix it if it is affected.

What it is: CVE-2019-1010268 is a critical vulnerability in Ladon, published on 18 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-1010268 in the wild and no public exploit code.

Affected packages and fixed versions:
- ladon (PyPI): affected from 0.6.1 up to 1.0.7; no fix listed
- ladon (PyPI): affected from 0.6.1 up to 1.0.7; no fix listed
- ladon (PyPI): affected from 0.6.1; fixed in 1.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1010268/ (Markdown: https://insights.sbomify.com/CVE-2019-1010268/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1010268
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1010268
- OSV: https://osv.dev/vulnerability/CVE-2019-1010268

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1010268/
Summaries are generated and may contain mistakes; the official description above is the record.
