# CVE-2019-1010275: Helm Improper Certificate Validation

> Helm allowed unauthorized clients to connect via self-signed certificates, bypassing authentication controls.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-x6r5-vxfg-gq3v, GO-2023-1993, UBUNTU-CVE-2019-1010275

## What is CVE-2019-1010275?

CVE-2019-1010275 is a critical vulnerability in helm, published on 17 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

helm Before 2.7.2 is affected by: CWE-295: Improper Certificate Validation. The impact is: Unauthorized clients could connect to the server because self-signed client certs were aloowed. The component is: helm (many files updated, see https://github.com/helm/helm/pull/3152/files/1096813bf9a425e2aa4ac755b6c991b626dfab50). The attack vector is: A malicious client could connect to the server over the network. The fixed version is: 2.7.2.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2019-1010275?

3 open source packages ship an affected version, including helm.sh/helm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `helm.sh/helm` | Go | All versions | 2.7.2 |
| `helm.sh/helm` | Go | All versions | 2.7.2 |
| `helm.sh/helm` | Go | All versions | 2.7.2+incompatible |

Products: Helm Helm.

## How do I fix CVE-2019-1010275?

Upgrade helm.sh/helm to a fixed version for your release line: 2.7.2 or 2.7.2+incompatible.

## Is CVE-2019-1010275 being exploited?

There is no known exploitation of CVE-2019-1010275 in the wild and no public exploit code.

## Other vulnerabilities in helm

- [CVE-2019-18658](https://insights.sbomify.com/CVE-2019-18658/): Helm Unsafe Link Following (critical 9.8)
- [CVE-2019-25210](https://insights.sbomify.com/CVE-2019-25210/): Information disclosure in n/a (critical 9.1)
- [CVE-2025-53547](https://insights.sbomify.com/CVE-2025-53547/): Helm Chart Dependency Updating With Malicious Chart.yaml Content And Symlink Can Lead To Code Execution (high 8.5)
- [CVE-2020-11013](https://insights.sbomify.com/CVE-2020-11013/): lookup Function Information Discolosure in Helm (high 8.5)
- [CVE-2026-35204](https://insights.sbomify.com/CVE-2026-35204/): Helm has a path traversal in plugin metadata version enables arbitrary file write outside Helm plugin directory (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1010275 and fix it if it is affected.

What it is: CVE-2019-1010275 is a critical vulnerability in helm, published on 17 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-1010275 in the wild and no public exploit code.

Affected packages and fixed versions:
- helm.sh/helm (Go): affected all versions; fixed in 2.7.2
- helm.sh/helm (Go): affected all versions; fixed in 2.7.2
- helm.sh/helm (Go): affected all versions; fixed in 2.7.2+incompatible

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1010275/ (Markdown: https://insights.sbomify.com/CVE-2019-1010275/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1010275
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1010275
- OSV: https://osv.dev/vulnerability/CVE-2019-1010275

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1010275/
Summaries are generated and may contain mistakes; the official description above is the record.
