CVE-2019-1010293 Memory corruption in OP-TEE

Critical 9.8 Published Updated

Attackers can corrupt TEE memory via boundary crossing, potentially executing code or escalating privileges in Linaro OP-TEE.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2019-1010293?

CVE-2019-1010293 is a critical memory corruption vulnerability in Linaro/OP-TEE OP-TEE, published on 15 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Linaro/OP-TEE OP-TEE 3.3.0 and earlier is affected by: Boundary crossing. The impact is: Memory corruption of the TEE itself. The component is: optee_os. The fixed version is: 3.4.0 and later.

Weakness: CWE-787

Which versions are affected by CVE-2019-1010293?

It affects 1 product.

Products include Trustedfirmware Op-Tee.

How do I fix CVE-2019-1010293?

No fix has been published for CVE-2019-1010293 yet. Limit exposure of the affected software until one is available.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2019-1010293 being exploited?

There is no known exploitation of CVE-2019-1010293 in the wild and no public exploit code.

Sources

Also known as GHSA-43r2-vc56-g759.

Is CVE-2019-1010293 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free