CVE-2019-1010295 Linaro/OP-TEE OP-TEE 3.3.0 and earlier is affected by: Buffer Overflow.

Critical 9.8 Published Updated
Exploited in the wild
Not known
Fix
None listed

What is CVE-2019-1010295?

CVE-2019-1010295 is a critical vulnerability in Linaro/OP-TEE OP-TEE, published on 15 Jul 2019.

Official description

Linaro/OP-TEE OP-TEE 3.3.0 and earlier is affected by: Buffer Overflow. The impact is: Memory corruption and disclosure of memory content. The component is: optee_os. The fixed version is: 3.4.0 and later.

Weakness: CWE-787, CWE-20, CWE-125

Which versions are affected by CVE-2019-1010295?

It affects 1 product.

Products include Trustedfirmware Op-Tee.

How do I fix CVE-2019-1010295?

No fix has been published for CVE-2019-1010295 yet. Limit exposure of the affected software until one is available.

Is CVE-2019-1010295 being exploited?

There is no known exploitation of CVE-2019-1010295 in the wild and no public exploit code.

Sources

Also known as GHSA-6535-4cfw-5c33.

Is CVE-2019-1010295 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free