# CVE-2019-1010295: Linaro/OP-TEE OP-TEE 3.3.0 and earlier is affected by: Buffer Overflow.


- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 15 Jul 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-6535-4cfw-5c33

## What is CVE-2019-1010295?

CVE-2019-1010295 is a critical vulnerability in Linaro/OP-TEE OP-TEE, published on 15 Jul 2019. 

### Official description

Linaro/OP-TEE OP-TEE 3.3.0 and earlier is affected by: Buffer Overflow. The impact is: Memory corruption and disclosure of memory content. The component is: optee_os. The fixed version is: 3.4.0 and later.

Weakness: CWE-787 (Out-of-bounds Write), CWE-20 (Improper Input Validation), CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2019-1010295?

It affects 1 product.


Products: Trustedfirmware Op-Tee.

## How do I fix CVE-2019-1010295?

No fix has been published for CVE-2019-1010295 yet. Limit exposure of the affected software until one is available.

## Is CVE-2019-1010295 being exploited?

There is no known exploitation of CVE-2019-1010295 in the wild and no public exploit code.

## Other vulnerabilities in Linaro/OP-TEE OP-TEE

- [CVE-2019-1010292](https://insights.sbomify.com/CVE-2019-1010292/): Memory corruption in OP-TEE (critical 9.8)
- [CVE-2019-1010293](https://insights.sbomify.com/CVE-2019-1010293/): Memory corruption in OP-TEE (critical 9.8)
- [CVE-2019-1010296](https://insights.sbomify.com/CVE-2019-1010296/): Memory corruption in OP-TEE (critical 9.8)
- [CVE-2019-1010297](https://insights.sbomify.com/CVE-2019-1010297/): Memory corruption in OP-TEE (critical 9.8)
- [CVE-2019-1010298](https://insights.sbomify.com/CVE-2019-1010298/): Memory corruption in OP-TEE (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1010295 and fix it if it is affected.

What it is: CVE-2019-1010295 is a critical vulnerability in Linaro/OP-TEE OP-TEE, published on 15 Jul 2019. 
Exploitation: There is no known exploitation of CVE-2019-1010295 in the wild and no public exploit code.

Affected product: Linaro/OP-TEE OP-TEE. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1010295/ (Markdown: https://insights.sbomify.com/CVE-2019-1010295/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1010295
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1010295
- OSV: https://osv.dev/vulnerability/CVE-2019-1010295

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1010295/
Summaries are generated and may contain mistakes; the official description above is the record.
