CVE-2019-1010297 Memory corruption in OP-TEE

Critical 9.8 Published Updated

A buffer overflow in OP-TEE OS allows attackers to execute arbitrary code within the Trusted Execution Environment kernel context.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2019-1010297?

CVE-2019-1010297 is a critical memory corruption vulnerability in Linaro/OP-TEE OP-TEE, published on 15 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Linaro/OP-TEE OP-TEE 3.3.0 and earlier is affected by: Buffer Overflow. The impact is: Execution of code in TEE core (kernel) context. The component is: optee_os. The fixed version is: 3.4.0 and later.

Weakness: CWE-787, CWE-190

Which versions are affected by CVE-2019-1010297?

It affects 1 product.

Products include Trustedfirmware Op-Tee.

How do I fix CVE-2019-1010297?

No fix has been published for CVE-2019-1010297 yet. Limit exposure of the affected software until one is available.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2019-1010297 being exploited?

There is no known exploitation of CVE-2019-1010297 in the wild and no public exploit code.

Sources

Also known as GHSA-fq75-vq38-pj5v.

Is CVE-2019-1010297 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free