CVE-2019-1010314 Gitea XSS Vulnerability in Repository Description
An attacker can execute arbitrary JavaScript in a victim's browser by injecting malicious code into a repository description, potentially leading to session hijacking or data theft.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2019-1010314?
CVE-2019-1010314 is a medium-severity cross-site scripting vulnerability in Gitea Gitea, published on 11 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Gitea 1.7.2, 1.7.3 is affected by: Cross Site Scripting (XSS). The impact is: execute JavaScript in victim's browser, when the vulnerable repo page is loaded. The component is: repository's description. The attack vector is: victim must navigate to public and affected repo page.
Weakness: CWE-79
Which versions are affected by CVE-2019-1010314?
2 open source packages ship an affected version, including code.gitea.io/gitea. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
code.gitea.io/gitea Go | From 1.7.2 | 1.7.4 |
code.gitea.io/gitea Go | From 1.7.2 | 1.7.4 |
Products include Gitea Gitea.
How do I fix CVE-2019-1010314?
Upgrade code.gitea.io/gitea to 1.7.4 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2019-1010314 being exploited?
There is no known exploitation of CVE-2019-1010314 in the wild and no public exploit code.
Other vulnerabilities in Gitea Gitea
Sources
Also known as GHSA-hqx2-j33x-9fc4, UBUNTU-CVE-2019-1010314.