# CVE-2019-1010314: Gitea XSS Vulnerability in Repository Description

> An attacker can execute arbitrary JavaScript in a victim's browser by injecting malicious code into a repository description, potentially leading to session hijacking or data theft.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Jul 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-hqx2-j33x-9fc4, UBUNTU-CVE-2019-1010314

## What is CVE-2019-1010314?

CVE-2019-1010314 is a medium-severity cross-site scripting vulnerability in Gitea Gitea, published on 11 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Gitea 1.7.2, 1.7.3 is affected by: Cross Site Scripting (XSS). The impact is: execute JavaScript in victim's browser, when the vulnerable repo page is loaded. The component is: repository's description. The attack vector is: victim must navigate to public and affected repo page.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-1010314?

2 open source packages ship an affected version, including code.gitea.io/gitea. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code.gitea.io/gitea` | Go | From 1.7.2 | 1.7.4 |
| `code.gitea.io/gitea` | Go | From 1.7.2 | 1.7.4 |

Products: Gitea Gitea.

## How do I fix CVE-2019-1010314?

Upgrade code.gitea.io/gitea to 1.7.4 or later.

## Is CVE-2019-1010314 being exploited?

There is no known exploitation of CVE-2019-1010314 in the wild and no public exploit code.

## Other vulnerabilities in Gitea Gitea

- [CVE-2026-60004](https://insights.sbomify.com/CVE-2026-60004/): Gitea Code Injection (critical 9.8, exploited in the wild)
- [CVE-2026-73278](https://insights.sbomify.com/CVE-2026-73278/): Gitea WebAuthn bypass during OAuth and OIDC sign-in (critical 9.8)
- [CVE-2026-94205](https://insights.sbomify.com/CVE-2026-94205/): Gitea fork workflow approval bypass through maintainer-triggered events (critical 9.8)
- [CVE-2022-42968](https://insights.sbomify.com/CVE-2022-42968/): Gitea vulnerable to Argument Injection (critical 9.8)
- [CVE-2021-45330](https://insights.sbomify.com/CVE-2021-45330/): Improper Privilege Management in Gitea (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1010314 and fix it if it is affected.

What it is: CVE-2019-1010314 is a medium-severity cross-site scripting vulnerability in Gitea Gitea, published on 11 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-1010314 in the wild and no public exploit code.

Affected packages and fixed versions:
- code.gitea.io/gitea (Go): affected from 1.7.2; fixed in 1.7.4
- code.gitea.io/gitea (Go): affected from 1.7.2; fixed in 1.7.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1010314/ (Markdown: https://insights.sbomify.com/CVE-2019-1010314/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1010314
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1010314
- OSV: https://osv.dev/vulnerability/CVE-2019-1010314

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1010314/
Summaries are generated and may contain mistakes; the official description above is the record.
