CVE-2019-10133 Moodle Open Redirect Vulnerability

Low 3.1 Published Updated

An attacker can redirect users to malicious external sites via the cohort upload form, potentially facilitating phishing attacks.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2019-10133?

CVE-2019-10133 is a low-severity vulnerability in Moodle Moodle, published on 26 Jun 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

A flaw was found in Moodle before 3.7, 3.6.4, 3.5.6, 3.4.9 and 3.1.18. The form to upload cohorts contained a redirect field, which was not restricted to internal URLs.

Weakness: CWE-601

Which versions are affected by CVE-2019-10133?

8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistAll versions3.1.18
moodle/moodle PackagistAll versions3.1.18
moodle/moodle PackagistFrom 3.4.03.4.9
moodle/moodle PackagistFrom 3.4.03.4.9
moodle/moodle PackagistFrom 3.5.03.5.6
moodle/moodle PackagistFrom 3.5.03.5.6
2 more packages
moodle/moodle PackagistFrom 3.6.03.6.4
moodle/moodle PackagistFrom 3.6.03.6.4

Products include Moodle Moodle.

How do I fix CVE-2019-10133?

Upgrade moodle/moodle to a fixed version for your release line: 3.1.18, 3.4.9, 3.5.6 or 3.6.4.

Is CVE-2019-10133 being exploited?

There is no known exploitation of CVE-2019-10133 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-5xp2-rv4h-mm2q, UBUNTU-CVE-2019-10133.

Is CVE-2019-10133 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free