CVE-2019-10134 Moodle Private files uploaded via incoming mail processing could bypass quota restrictions
Attackers can exceed private file upload quotas via email due to incorrect size checks, potentially exhausting storage resources.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-10134?
CVE-2019-10134 is a medium-severity vulnerability in Moodle Moodle, published on 26 Jun 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A flaw was found in Moodle before 3.7, 3.6.4, 3.5.6, 3.4.9 and 3.1.18. The size of users' private file uploads via email were not correctly checked, so their quota allowance could be exceeded.
Weakness: CWE-20
Which versions are affected by CVE-2019-10134?
8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.1 | 3.1.18 |
moodle/moodle Packagist | From 3.1 | 3.1.18 |
moodle/moodle Packagist | From 3.4 | 3.4.9 |
moodle/moodle Packagist | From 3.4 | 3.4.9 |
moodle/moodle Packagist | From 3.5 | 3.5.6 |
moodle/moodle Packagist | From 3.5 | 3.5.6 |
2 more packages
moodle/moodle Packagist | From 3.6 | 3.6.4 |
moodle/moodle Packagist | From 3.6 | 3.6.4 |
Products include Moodle Moodle.
How do I fix CVE-2019-10134?
Upgrade moodle/moodle to a fixed version for your release line: 3.1.18, 3.4.9, 3.5.6 or 3.6.4.
Is CVE-2019-10134 being exploited?
There is no known exploitation of CVE-2019-10134 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-j8wr-7xxj-c2fr, UBUNTU-CVE-2019-10134.