# CVE-2019-10152: Podman Path Traversal Vulnerability leads to arbitrary file read/write

> An attacker with container access can read or write arbitrary host files via symlink traversal when an administrator copies files using Podman.

- **Severity:** High 7.5 (`CVSS:3.0/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Jul 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-rh5f-2w6r-q7vj, GO-2023-1927, RHSA-2019:1907

## What is CVE-2019-10152?

CVE-2019-10152 is a high-severity path traversal vulnerability in Opensuse Leap, published on 30 Jul 2019. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

A path traversal vulnerability has been discovered in podman before version 1.4.0 in the way it handles symlinks inside containers. An attacker who has compromised an existing container can cause arbitrary files on the host filesystem to be read/written when an administrator tries to copy a file from/to the container.

Weakness: CWE-59 (Improper Link Resolution Before File Access), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2019-10152?

3 open source packages ship an affected version, including github.com/containers/podman. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/containers/podman` | Go | All versions | 1.4.0 |
| `github.com/containers/podman` | Go | All versions | 1.4.0 |
| `github.com/containers/podman` | Go | All versions | 1.4.0 |
| `podman` | Red Hat:rhel_extras_other:7 | All versions | 0:1.4.4-2.el7 |
| `podman-debuginfo` | Red Hat:rhel_extras_other:7 | All versions | 0:1.4.4-2.el7 |
| `podman-docker` | Red Hat:rhel_extras_other:7 | All versions | 0:1.4.4-2.el7 |

Products: Libpod Project Libpod, Opensuse Leap.

## How do I fix CVE-2019-10152?

Upgrade github.com/containers/podman to 1.4.0 or later.

## Is CVE-2019-10152 being exploited?

There is no known exploitation of CVE-2019-10152 in the wild and no public exploit code.

## Other vulnerabilities in Opensuse Leap

- [CVE-2020-1726](https://insights.sbomify.com/CVE-2020-1726/): Podman has Files or Directories Accessible to External Parties (medium 5.9)
- [CVE-2019-18466](https://insights.sbomify.com/CVE-2019-18466/): Podman Symlink Vulnerability (medium 5.5)
- [CVE-2018-10856](https://insights.sbomify.com/CVE-2018-10856/): Podman Elevated Container Privileges (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10152 and fix it if it is affected.

What it is: CVE-2019-10152 is a high-severity path traversal vulnerability in Opensuse Leap, published on 30 Jul 2019. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-10152 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/containers/podman (Go): affected all versions; fixed in 1.4.0
- github.com/containers/podman (Go): affected all versions; fixed in 1.4.0
- github.com/containers/podman (Go): affected all versions; fixed in 1.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10152/ (Markdown: https://insights.sbomify.com/CVE-2019-10152/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10152
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10152
- OSV: https://osv.dev/vulnerability/CVE-2019-10152

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10152/
Summaries are generated and may contain mistakes; the official description above is the record.
