CVE-2019-10154 Moodle all messaging conversations could be viewed
An attacker can read messages from other users' conversations because the web service lacks proper user restriction.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-10154?
CVE-2019-10154 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 26 Jun 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A flaw was found in Moodle before versions 3.7, 3.6.4. A web service fetching messages was not restricted to the current user's conversations.
Weakness: CWE-285
Which versions are affected by CVE-2019-10154?
2 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.6 | 3.6.4 |
moodle/moodle Packagist | From 3.6 | 3.6.4 |
Products include Moodle Moodle.
How do I fix CVE-2019-10154?
Upgrade moodle/moodle to 3.6.4 or later.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2019-10154 being exploited?
There is no known exploitation of CVE-2019-10154 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-ww45-x87c-wgff.