CVE-2019-10156 Exposure of Sensitive Information to an Unauthorized Actor in ansible
An attacker can disclose sensitive variable content through unexpected substitution in Ansible templating, affecting automation security.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2019-10156?
CVE-2019-10156 is a medium-severity vulnerability in Debian Debian Linux, published on 30 Jul 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
A flaw was discovered in the way Ansible templating was implemented in versions before 2.6.18, 2.7.12 and 2.8.2, causing the possibility of information disclosure through unexpected variable substitution. By taking advantage of unintended variable substitution the content of any variable may be disclosed.
Weakness: CWE-200
Which versions are affected by CVE-2019-10156?
7 open source packages ship an affected version, including ansible. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
ansible PyPI | All versions | 2.6.18, 2.7.12, 2.8.2 |
ansible PyPI | All versions | 2.6.18 |
ansible PyPI | All versions | 2.6.18 |
ansible PyPI | From 2.7.0a1 | 2.7.12 |
ansible PyPI | From 2.7.0a1 | 2.7.12 |
ansible PyPI | From 2.8.0a1 | 2.8.2 |
1 more packages
ansible PyPI | From 2.8.0a1 | 2.8.2 |
Linux distribution packages (6)
ansible Red Hat:ansible_engine:2.6::el7 | All versions | 0:2.6.18-1.el7ae |
ansible Red Hat:ansible_engine:2.7::el7 | All versions | 0:2.7.12-1.el7ae |
ansible Red Hat:ansible_engine:2.8::el7 | All versions | 0:2.8.2-1.el7ae |
ansible Red Hat:ansible_engine:2.8::el8 | All versions | 0:2.8.2-1.el8ae |
ansible Red Hat:ansible_engine:2::el7 | All versions | 0:2.8.2-1.el7ae |
ansible Red Hat:ansible_engine:2::el8 | All versions | 0:2.8.2-1.el8ae |
Products include Debian Debian Linux, Redhat Ansible, Redhat Openstack.
How do I fix CVE-2019-10156?
Upgrade ansible to a fixed version for your release line: 2.6.18, 2.7.12 or 2.8.2.
Is CVE-2019-10156 being exploited?
There is no known exploitation of CVE-2019-10156 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALPINE-CVE-2019-10156, DEBIAN-CVE-2019-10156, GHSA-grgm-pph5-j5h7, MGASA-2019-0234, OESA-2021-1400, PYSEC-2019-2 and 5 more.