# CVE-2019-10156: Exposure of Sensitive Information to an Unauthorized Actor in ansible

> An attacker can disclose sensitive variable content through unexpected substitution in Ansible templating, affecting automation security.

- **Severity:** Medium 4.6 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Jul 2019
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2019-10156, DEBIAN-CVE-2019-10156, GHSA-grgm-pph5-j5h7, MGASA-2019-0234, OESA-2021-1400, PYSEC-2019-2, RHSA-2019:1705, RHSA-2019:1706, RHSA-2019:1707, RHSA-2019:1708, UBUNTU-CVE-2019-10156

## What is CVE-2019-10156?

CVE-2019-10156 is a medium-severity vulnerability in Debian Debian Linux, published on 30 Jul 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A flaw was discovered in the way Ansible templating was implemented in versions before 2.6.18, 2.7.12 and 2.8.2, causing the possibility of information disclosure through unexpected variable substitution. By taking advantage of unintended variable substitution the content of any variable may be disclosed.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2019-10156?

7 open source packages ship an affected version, including ansible. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | All versions | 2.6.18, 2.7.12, 2.8.2 |
| `ansible` | PyPI | All versions | 2.6.18 |
| `ansible` | PyPI | All versions | 2.6.18 |
| `ansible` | PyPI | From 2.7.0a1 | 2.7.12 |
| `ansible` | PyPI | From 2.7.0a1 | 2.7.12 |
| `ansible` | PyPI | From 2.8.0a1 | 2.8.2 |
| `ansible` | PyPI | From 2.8.0a1 | 2.8.2 |
| `ansible` | Red Hat:ansible_engine:2.6::el7 | All versions | 0:2.6.18-1.el7ae |
| `ansible` | Red Hat:ansible_engine:2.7::el7 | All versions | 0:2.7.12-1.el7ae |
| `ansible` | Red Hat:ansible_engine:2.8::el7 | All versions | 0:2.8.2-1.el7ae |
| `ansible` | Red Hat:ansible_engine:2.8::el8 | All versions | 0:2.8.2-1.el8ae |
| `ansible` | Red Hat:ansible_engine:2::el7 | All versions | 0:2.8.2-1.el7ae |
| `ansible` | Red Hat:ansible_engine:2::el8 | All versions | 0:2.8.2-1.el8ae |

Products: Debian Debian Linux, Redhat Ansible, Redhat Openstack.

## How do I fix CVE-2019-10156?

Upgrade ansible to a fixed version for your release line: 2.6.18, 2.7.12 or 2.8.2.

## Is CVE-2019-10156 being exploited?

There is no known exploitation of CVE-2019-10156 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10156 and fix it if it is affected.

What it is: CVE-2019-10156 is a medium-severity vulnerability in Debian Debian Linux, published on 30 Jul 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-10156 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected all versions; fixed in 2.6.18, 2.7.12, 2.8.2
- ansible (PyPI): affected all versions; fixed in 2.6.18
- ansible (PyPI): affected all versions; fixed in 2.6.18
- ansible (PyPI): affected from 2.7.0a1; fixed in 2.7.12
- ansible (PyPI): affected from 2.7.0a1; fixed in 2.7.12
- ansible (PyPI): affected from 2.8.0a1; fixed in 2.8.2
- ansible (PyPI): affected from 2.8.0a1; fixed in 2.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10156/ (Markdown: https://insights.sbomify.com/CVE-2019-10156/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10156
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10156
- OSV: https://osv.dev/vulnerability/CVE-2019-10156

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10156/
Summaries are generated and may contain mistakes; the official description above is the record.
