# CVE-2019-10157: Forced Logout in keycloak-connect

> An attacker with local access can craft a malicious token to prevent user access indefinitely due to improper token verification in the Keycloak Node.js adapter.

- **Severity:** Medium 4.7 (`CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-68hw-vfh7-xvg8

## What is CVE-2019-10157?

CVE-2019-10157 is a medium-severity authentication bypass vulnerability in Redhat Keycloak, published on 12 Jun 2019. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

It was found that Keycloak's Node.js adapter before version 4.8.3 did not properly verify the web token received from the server in its backchannel logout . An attacker with local access could use this to construct a malicious web token setting an NBF parameter that could prevent user access indefinitely.

Weakness: CWE-287 (Improper Authentication), CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2019-10157?

2 open source packages ship an affected version, including keycloak-connect. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keycloak-connect` | npm | All versions | 4.8.3 |
| `keycloak-connect` | npm | All versions | 4.8.3 |

Products: Redhat Keycloak, Redhat Single Sign-On.

## How do I fix CVE-2019-10157?

Upgrade keycloak-connect to 4.8.3 or later.

## Is CVE-2019-10157 being exploited?

There is no known exploitation of CVE-2019-10157 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Keycloak

- [CVE-2022-4361](https://insights.sbomify.com/CVE-2022-4361/): Keycloak vulnerable to cross-site scripting when validating URI-schemes on SAML and OIDC (critical 10.0)
- [CVE-2022-1245](https://insights.sbomify.com/CVE-2022-1245/): Keycloak vulnerable to privilege escalation on Token Exchange feature (critical 9.8)
- [CVE-2021-20195](https://insights.sbomify.com/CVE-2021-20195/): keycloak Self Stored Cross-site Scripting vulnerability (critical 9.6)
- [CVE-2019-14910](https://insights.sbomify.com/CVE-2019-14910/): Keycloak Authentication Error (critical 9.3)
- [CVE-2019-14909](https://insights.sbomify.com/CVE-2019-14909/): Keycloak Authentication Error (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10157 and fix it if it is affected.

What it is: CVE-2019-10157 is a medium-severity authentication bypass vulnerability in Redhat Keycloak, published on 12 Jun 2019. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10157 in the wild and no public exploit code.

Affected packages and fixed versions:
- keycloak-connect (npm): affected all versions; fixed in 4.8.3
- keycloak-connect (npm): affected all versions; fixed in 4.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10157/ (Markdown: https://insights.sbomify.com/CVE-2019-10157/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10157
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10157
- OSV: https://osv.dev/vulnerability/CVE-2019-10157

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10157/
Summaries are generated and may contain mistakes; the official description above is the record.
