# CVE-2019-10170: Privilege Defined With Unsafe Actions in Keycloak

> Authenticated realm administrators can inject malicious scripts via policy settings to execute arbitrary code on the Keycloak server.

- **Severity:** Medium 6.6 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-7m27-3587-83xf

## What is CVE-2019-10170?

CVE-2019-10170 is a medium-severity code injection vulnerability in Redhat Keycloak, published on 8 May 2020. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A flaw was found in the Keycloak admin console, where the realm management interface permits a script to be set via the policy. This flaw allows an attacker with authenticated user and realm management permissions to configure a malicious script to trigger and execute arbitrary code with the permissions of the application user.

Weakness: CWE-267 (Privilege Defined With Unsafe Actions)

## Which versions are affected by CVE-2019-10170?

2 open source packages ship an affected version, including org.keycloak:keycloak-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-core` | Maven | All versions | 8.0.0 |
| `org.keycloak:keycloak-core` | Maven | All versions | 8.0.0 |

Products: Redhat Keycloak.

## How do I fix CVE-2019-10170?

Upgrade org.keycloak:keycloak-core to 8.0.0 or later.

## Is CVE-2019-10170 being exploited?

There is no known exploitation of CVE-2019-10170 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Keycloak

- [CVE-2022-4361](https://insights.sbomify.com/CVE-2022-4361/): Keycloak vulnerable to cross-site scripting when validating URI-schemes on SAML and OIDC (critical 10.0)
- [CVE-2022-1245](https://insights.sbomify.com/CVE-2022-1245/): Keycloak vulnerable to privilege escalation on Token Exchange feature (critical 9.8)
- [CVE-2021-20195](https://insights.sbomify.com/CVE-2021-20195/): keycloak Self Stored Cross-site Scripting vulnerability (critical 9.6)
- [CVE-2019-14910](https://insights.sbomify.com/CVE-2019-14910/): Keycloak Authentication Error (critical 9.3)
- [CVE-2019-14909](https://insights.sbomify.com/CVE-2019-14909/): Keycloak Authentication Error (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10170 and fix it if it is affected.

What it is: CVE-2019-10170 is a medium-severity code injection vulnerability in Redhat Keycloak, published on 8 May 2020. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10170 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 8.0.0
- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 8.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10170/ (Markdown: https://insights.sbomify.com/CVE-2019-10170/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10170
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10170
- OSV: https://osv.dev/vulnerability/CVE-2019-10170

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10170/
Summaries are generated and may contain mistakes; the official description above is the record.
