CVE-2019-10186 Moodle CSRF Vulnerability
Attackers can perform unauthorized actions via the XML admin tool due to missing CSRF token validation in Moodle.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-10186?
CVE-2019-10186 is a medium-severity vulnerability in Moodle Moodle, published on 31 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A flaw was found in moodle before versions 3.7.1, 3.6.5, 3.5.7. A sesskey (CSRF) token was not being utilised by the XML loading/unloading admin tool.
Weakness: CWE-352
Which versions are affected by CVE-2019-10186?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.5.0 | 3.5.7 |
moodle/moodle Packagist | From 3.5.0 | 3.5.7 |
moodle/moodle Packagist | From 3.6.0 | 3.6.5 |
moodle/moodle Packagist | From 3.6.0 | 3.6.5 |
moodle/moodle Packagist | From 3.7.0 | 3.7.1 |
moodle/moodle Packagist | From 3.7.0 | 3.7.1 |
Products include Moodle Moodle.
How do I fix CVE-2019-10186?
Upgrade moodle/moodle to a fixed version for your release line: 3.5.7, 3.6.5 or 3.7.1.
Is CVE-2019-10186 being exploited?
There is no known exploitation of CVE-2019-10186 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-wv9c-pfpm-4wc5, UBUNTU-CVE-2019-10186.