CVE-2019-10187 Moodle Ability to delete glossary entries that belong to another glossary

Medium 4.0 Published Updated

Users with glossary deletion permissions can delete entries from other glossaries they lack access to, compromising data integrity.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2019-10187?

CVE-2019-10187 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 31 Jul 2019. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

A flaw was found in moodle before versions 3.7.1, 3.6.5, 3.5.7. Users with permission to delete entries from a glossary were able to delete entries from other glossaries they did not have direct access to.

Weakness: CWE-862, CWE-284

Which versions are affected by CVE-2019-10187?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistFrom 3.53.5.7
moodle/moodle PackagistFrom 3.53.5.7
moodle/moodle PackagistFrom 3.63.6.5
moodle/moodle PackagistFrom 3.63.6.5
moodle/moodle PackagistFrom 3.73.7.1
moodle/moodle PackagistFrom 3.73.7.1

Products include Moodle Moodle.

How do I fix CVE-2019-10187?

Upgrade moodle/moodle to a fixed version for your release line: 3.5.7, 3.6.5 or 3.7.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2019-10187 being exploited?

There is no known exploitation of CVE-2019-10187 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-2mg9-hv69-897x, UBUNTU-CVE-2019-10187.

Is CVE-2019-10187 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free