# CVE-2019-10187: Moodle Ability to delete glossary entries that belong to another glossary

> Users with glossary deletion permissions can delete entries from other glossaries they lack access to, compromising data integrity.

- **Severity:** Medium 4.0 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jul 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-2mg9-hv69-897x, UBUNTU-CVE-2019-10187

## What is CVE-2019-10187?

CVE-2019-10187 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 31 Jul 2019. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A flaw was found in moodle before versions 3.7.1, 3.6.5, 3.5.7. Users with permission to delete entries from a glossary were able to delete entries from other glossaries they did not have direct access to.

Weakness: CWE-862 (Missing Authorization), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2019-10187?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | From 3.5 | 3.5.7 |
| `moodle/moodle` | Packagist | From 3.5 | 3.5.7 |
| `moodle/moodle` | Packagist | From 3.6 | 3.6.5 |
| `moodle/moodle` | Packagist | From 3.6 | 3.6.5 |
| `moodle/moodle` | Packagist | From 3.7 | 3.7.1 |
| `moodle/moodle` | Packagist | From 3.7 | 3.7.1 |

Products: Moodle Moodle.

## How do I fix CVE-2019-10187?

Upgrade moodle/moodle to a fixed version for your release line: 3.5.7, 3.6.5 or 3.7.1.

## Is CVE-2019-10187 being exploited?

There is no known exploitation of CVE-2019-10187 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10187 and fix it if it is affected.

What it is: CVE-2019-10187 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 31 Jul 2019. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10187 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected from 3.5; fixed in 3.5.7
- moodle/moodle (Packagist): affected from 3.5; fixed in 3.5.7
- moodle/moodle (Packagist): affected from 3.6; fixed in 3.6.5
- moodle/moodle (Packagist): affected from 3.6; fixed in 3.6.5
- moodle/moodle (Packagist): affected from 3.7; fixed in 3.7.1
- moodle/moodle (Packagist): affected from 3.7; fixed in 3.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10187/ (Markdown: https://insights.sbomify.com/CVE-2019-10187/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10187
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10187
- OSV: https://osv.dev/vulnerability/CVE-2019-10187

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10187/
Summaries are generated and may contain mistakes; the official description above is the record.
