CVE-2019-10189 moodle Improper Access Control

Medium 4.0 Published Updated

Teachers can improperly modify group overrides for other groups in the same assignment, allowing unauthorized data modification.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2019-10189?

CVE-2019-10189 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 31 Jul 2019. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

A flaw was found in moodle before versions 3.7.1, 3.6.5, 3.5.7. Teachers in an assignment group could modify group overrides for other groups in the same assignment.

Weakness: CWE-284

Which versions are affected by CVE-2019-10189?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistAll versions3.5.7
moodle/moodle PackagistAll versions3.5.7
moodle/moodle PackagistFrom 3.6.03.6.5
moodle/moodle PackagistFrom 3.6.03.6.5
moodle/moodle PackagistFrom 3.7.03.7.1
moodle/moodle PackagistFrom 3.7.03.7.1

Products include Moodle Moodle.

How do I fix CVE-2019-10189?

Upgrade moodle/moodle to a fixed version for your release line: 3.5.7, 3.6.5 or 3.7.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2019-10189 being exploited?

There is no known exploitation of CVE-2019-10189 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-h7xp-7fjp-ghhc, UBUNTU-CVE-2019-10189.

Is CVE-2019-10189 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free