# CVE-2019-10195: FreeIPA logs passwords embedded in commands in calls using batch

> Attackers with log access can read clear-text passwords exposed by FreeIPA's batch processing API, which is disabled by default but enabled by third-party components.

- **Severity:** Medium 5.7 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Nov 2019
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-10195, GHSA-w4q7-f34x-vpgc, PYSEC-2019-168, PYSEC-2019-22, UBUNTU-CVE-2019-10195

## What is CVE-2019-10195?

CVE-2019-10195 is a medium-severity vulnerability in Fedoraproject Fedora, published on 27 Nov 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A flaw was found in IPA, all 4.6.x versions before 4.6.7, all 4.7.x versions before 4.7.4 and all 4.8.x versions before 4.8.3, in the way that FreeIPA's batch processing API logged operations. This included passing user passwords in clear text on FreeIPA masters. Batch processing of commands with passwords as arguments or options is not performed by default in FreeIPA but is possible by third-party components. An attacker having access to system logs on FreeIPA masters could use this flaw to produce log file content with passwords exposed.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2019-10195?

14 open source packages ship an affected version, including freeipa and ipa. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `freeipa` | PyPI | From 4.6.0 | 4.6.7 |
| `freeipa` | PyPI | From 4.6.0 | 4.6.7 |
| `freeipa` | PyPI | From 4.6.1 | 4.6.7, 4.7.4, 4.8.3 |
| `freeipa` | PyPI | From 4.7.0 | 4.7.4 |
| `freeipa` | PyPI | From 4.7.0 | 4.7.4 |
| `freeipa` | PyPI | From 4.8.0 | 4.8.3 |
| `freeipa` | PyPI | From 4.8.0 | 4.8.3 |
| `ipa` | PyPI | From 4.6.0 | 4.6.7, 4.7.4, 4.8.3 |
| `ipa` | PyPI | From 4.6.0 | 4.6.7 |
| `ipa` | PyPI | From 4.6.0 | 4.6.7 |
| `ipa` | PyPI | From 4.7.0 | 4.7.4 |
| `ipa` | PyPI | From 4.7.0 | 4.7.4 |
| `ipa` | PyPI | From 4.8.0 | 4.8.3 |
| `ipa` | PyPI | From 4.8.0 | 4.8.3 |

Products: Fedoraproject Fedora, Freeipa Freeipa.

## How do I fix CVE-2019-10195?

Upgrade freeipa to a fixed version for your release line: 4.6.7, 4.7.4 or 4.8.3.

## Is CVE-2019-10195 being exploited?

There is no known exploitation of CVE-2019-10195 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10195 and fix it if it is affected.

What it is: CVE-2019-10195 is a medium-severity vulnerability in Fedoraproject Fedora, published on 27 Nov 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-10195 in the wild and no public exploit code.

Affected packages and fixed versions:
- freeipa (PyPI): affected from 4.6.0; fixed in 4.6.7
- freeipa (PyPI): affected from 4.6.0; fixed in 4.6.7
- freeipa (PyPI): affected from 4.6.1; fixed in 4.6.7, 4.7.4, 4.8.3
- freeipa (PyPI): affected from 4.7.0; fixed in 4.7.4
- freeipa (PyPI): affected from 4.7.0; fixed in 4.7.4
- freeipa (PyPI): affected from 4.8.0; fixed in 4.8.3
- freeipa (PyPI): affected from 4.8.0; fixed in 4.8.3
- ipa (PyPI): affected from 4.6.0; fixed in 4.6.7, 4.7.4, 4.8.3
- ipa (PyPI): affected from 4.6.0; fixed in 4.6.7
- ipa (PyPI): affected from 4.6.0; fixed in 4.6.7
- ipa (PyPI): affected from 4.7.0; fixed in 4.7.4
- ipa (PyPI): affected from 4.7.0; fixed in 4.7.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10195/ (Markdown: https://insights.sbomify.com/CVE-2019-10195/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10195
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10195
- OSV: https://osv.dev/vulnerability/CVE-2019-10195

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10195/
Summaries are generated and may contain mistakes; the official description above is the record.
