{"answers":{"affected":"2 open source packages ship an affected version, including http-proxy-agent. It affects 4 products.","exploited":"There is no known exploitation of CVE-2019-10196 in the wild and no public exploit code.","fix":"Upgrade http-proxy-agent to 2.1.0 or later.","what":"CVE-2019-10196 is a critical vulnerability in Fedoraproject Fedora, published on 19 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-10196 and fix it if it is affected.\n\nWhat it is: CVE-2019-10196 is a critical vulnerability in Fedoraproject Fedora, published on 19 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-10196 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- http-proxy-agent (npm): affected all versions; fixed in 2.1.0\n- http-proxy-agent (npm): affected all versions; fixed in 2.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-10196/ (Markdown: https://insights.sbomify.com/CVE-2019-10196/index.md)","id":"CVE-2019-10196","markdown":"https://insights.sbomify.com/CVE-2019-10196/index.md","name":"CVE-2019-10196","record":{"aliases":["GHSA-86wf-436m-h424"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js HTTP proxy library","requires_auth":"none","summary":"An attacker can cause denial of service and leak uninitialized memory by submitting typed input to the auth parameter in http-proxy-agent.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"http-proxy-agent","vendor":"http-proxy-agent_project"},{"product":"enterprise_linux","vendor":"redhat"},{"product":"software_collections","vendor":"redhat"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-665","name":"Improper Initialization"}],"description":"A flaw was found in http-proxy-agent, prior to version 2.1.0. It was discovered http-proxy-agent passes an auth option to the Buffer constructor without proper sanitization. This could result in a Denial of Service through the usage of all available CPU resources and data exposure through an uninitialized memory leak in setups where an attacker could submit typed input to the auth parameter.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Resource Exhaustion Denial of Service in http-proxy-agent","id":"CVE-2019-10196","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"fedoraproject:fedora","products":["fedoraproject:fedora","redhat:enterprise_linux","redhat:software_collections"],"type":"information_disclosure","year":"2019"},"n_packages":2,"n_references":2,"next":{"headline":"Path traversal in samba","id":"CVE-2019-10197"},"packages":[{"ecosystem":"npm","fixed":["2.1.0"],"introduced":["0"],"last_affected":[],"package":"http-proxy-agent","purl":null,"source":"GHSA-86wf-436m-h424"},{"ecosystem":"npm","fixed":["2.1.0"],"introduced":["0"],"last_affected":[],"package":"http-proxy-agent","purl":"pkg:npm/http-proxy-agent","source":"GHSA-86wf-436m-h424"}],"prev":{"headline":"FreeIPA logs passwords embedded in commands in calls using batch","id":"CVE-2019-10195"},"products":["nodejs-http-proxy-agent"],"published":"2021-03-19","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"An attacker can cause denial of service and leak uninitialized memory by submitting typed input to the auth parameter in http-proxy-agent.","url":"https://insights.sbomify.com/CVE-2019-10196/"}