CVE-2019-1020003 Cross-site scripting invenio-records
Medium 5.4
Published
Updated
Check this codebase for CVE-2019-1020003 and fix it if it is affected.
What it is: CVE-2019-1020003 is a medium-severity vulnerability in invenio-records, published on 29 Jul 2019.
Exploitation: There is no known exploitation of CVE-2019-1020003 in the wild and no public exploit code.
Affected packages and fixed versions:
- invenio-records (PyPI): affected all versions; fixed in 1.0.2
- invenio-records (PyPI): affected all versions; fixed in 1.0.2
- invenio-records (PyPI): affected all versions; fixed in 1.0.2
- invenio-records (PyPI): affected from 1.1.0; fixed in 1.1.1
- invenio-records (PyPI): affected from 1.1.0; fixed in 1.1.1
- invenio-records (PyPI): affected from 1.2.0; fixed in 1.2.2
- invenio-records (PyPI): affected from 1.2.0; fixed in 1.2.2
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2019-1020003/ (Markdown: https://insights.sbomify.com/CVE-2019-1020003/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2019-1020003?
CVE-2019-1020003 is a medium-severity vulnerability in invenio-records, published on 29 Jul 2019.
Official description
invenio-records before 1.2.2 allows XSS.
Weakness: CWE-79
Which versions are affected by CVE-2019-1020003?
7 open source packages ship an affected version, including invenio-records. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
invenio-records PyPI | All versions | 1.0.2 |
invenio-records PyPI | All versions | 1.0.2 |
invenio-records PyPI | All versions | 1.0.2 |
invenio-records PyPI | From 1.1.0 | 1.1.1 |
invenio-records PyPI | From 1.1.0 | 1.1.1 |
invenio-records PyPI | From 1.2.0 | 1.2.2 |
1 more packages
invenio-records PyPI | From 1.2.0 | 1.2.2 |
Products include Inveniosoftware Invenio-Records.
How do I fix CVE-2019-1020003?
Upgrade invenio-records to a fixed version for your release line: 1.0.2, 1.1.1 or 1.2.2.
Is CVE-2019-1020003 being exploited?
There is no known exploitation of CVE-2019-1020003 in the wild and no public exploit code.
Sources
Also known as GHSA-vxh3-mvv7-265j, PYSEC-2019-27.