{"answers":{"affected":"2 open source packages ship an affected version, including parse-server. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-1020013 in the wild and no public exploit code.","fix":"Upgrade parse-server to 3.6.0 or later.","what":"CVE-2019-1020013 is a medium-severity vulnerability in Parseplatform Parse-Server, published on 29 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-1020013 and fix it if it is affected.\n\nWhat it is: CVE-2019-1020013 is a medium-severity vulnerability in Parseplatform Parse-Server, published on 29 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-1020013 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- parse-server (npm): affected all versions; fixed in 3.6.0\n- parse-server (npm): affected all versions; fixed in 3.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-1020013/ (Markdown: https://insights.sbomify.com/CVE-2019-1020013/index.md)","id":"CVE-2019-1020013","markdown":"https://insights.sbomify.com/CVE-2019-1020013/index.md","name":"CVE-2019-1020013","record":{"aliases":["GHSA-8w3j-g983-8jh5"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Parse Server","requires_auth":"none","summary":"An attacker can enumerate valid user accounts on Parse Server instances, potentially facilitating targeted attacks.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"dwf","cpe":[{"product":"parse-server","vendor":"parseplatform"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-209","name":"Generation of Error Message Containing Sensitive Information"}],"description":"parse-server before 3.6.0 allows account enumeration.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Sensitive Data Exposure in parse-server","id":"CVE-2019-1020013","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"parseplatform:parse-server","products":["parseplatform:parse-server"],"type":"information_disclosure","year":"2019"},"n_packages":2,"n_references":1,"next":{"headline":"Use after free in docker-credential-helpers","id":"CVE-2019-1020014"},"packages":[{"ecosystem":"npm","fixed":["3.6.0"],"introduced":["0"],"last_affected":[],"package":"parse-server","purl":null,"source":"GHSA-8w3j-g983-8jh5"},{"ecosystem":"npm","fixed":["3.6.0"],"introduced":["0"],"last_affected":[],"package":"parse-server","purl":"pkg:npm/parse-server","source":"GHSA-8w3j-g983-8jh5"}],"prev":{"headline":"Parse Server before v3.4.1 vulnerable to Denial of Service","id":"CVE-2019-1020012"},"products":["parse-server"],"published":"2019-07-29","related":[{"cvss_score":10,"headline":"Parse Server role escalation and CLP bypass via direct `_Join` table write","id":"CVE-2026-30966","kev_date_added":null,"published":"2026-03-10"},{"cvss_score":10,"headline":"Parse Server literalizeRegexPart SQL Injection","id":"CVE-2024-27298","kev_date_added":null,"published":"2024-03-01"},{"cvss_score":10,"headline":"Command Injection in Parse server","id":"CVE-2022-24760","kev_date_added":null,"published":"2022-03-11"},{"cvss_score":9.9,"headline":"Parse Server session token exfiltration via `redirectClassNameForKey` query parameter","id":"CVE-2026-30965","kev_date_added":null,"published":"2026-03-10"},{"cvss_score":9.8,"headline":"Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution","id":"CVE-2023-36475","kev_date_added":null,"published":"2023-06-28"},{"cvss_score":9.8,"headline":"Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser","id":"CVE-2022-39396","kev_date_added":null,"published":"2022-11-10"},{"cvss_score":9.3,"headline":"Parse Server: Account takeover via operator injection in authentication data identifier","id":"CVE-2026-32248","kev_date_added":null,"published":"2026-03-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Parse"]},"summary":"An attacker can enumerate valid user accounts on Parse Server instances, potentially facilitating targeted attacks.","url":"https://insights.sbomify.com/CVE-2019-1020013/"}