{"answers":{"affected":"3 open source packages ship an affected version, including invenio-previewer. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-1020019 in the wild and no public exploit code.","fix":"Upgrade invenio-previewer to 1.0.0a12 or later.","what":"CVE-2019-1020019 is a medium-severity cross-site scripting vulnerability in invenio-previewer, published on 29 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-1020019 and fix it if it is affected.\n\nWhat it is: CVE-2019-1020019 is a medium-severity cross-site scripting vulnerability in invenio-previewer, published on 29 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-1020019 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- invenio-previewer (PyPI): affected all versions; fixed in 1.0.0a12\n- invenio-previewer (PyPI): affected all versions; fixed in 1.0.0a12\n- invenio-previewer (PyPI): affected all versions; fixed in 1.0.0a12\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-1020019/ (Markdown: https://insights.sbomify.com/CVE-2019-1020019/index.md)","id":"CVE-2019-1020019","markdown":"https://insights.sbomify.com/CVE-2019-1020019/index.md","name":"CVE-2019-1020019","record":{"aliases":["GHSA-j9m2-6hq2-4r3c","PYSEC-2019-26"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python previewer library","requires_auth":"none","summary":"An XSS vulnerability in the invenio-previewer library allows attackers to inject malicious scripts, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"dwf","cpe":[{"product":"invenio-previewer","vendor":"inveniosoftware"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"invenio-previewer before 1.0.0a12 allows XSS.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting in invenio-previewer","id":"CVE-2019-1020019","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":3,"n_references":1,"next":{"headline":"Privilege escalation in Android","id":"CVE-2020-0001"},"packages":[{"ecosystem":"PyPI","fixed":["1.0.0a12"],"introduced":["0"],"last_affected":[],"package":"invenio-previewer","purl":null,"source":"GHSA-j9m2-6hq2-4r3c"},{"ecosystem":"PyPI","fixed":["1.0.0a12"],"introduced":["0"],"last_affected":[],"package":"invenio-previewer","purl":"pkg:pypi/invenio-previewer","source":"GHSA-j9m2-6hq2-4r3c"},{"ecosystem":"PyPI","fixed":["1.0.0a12"],"introduced":["0"],"last_affected":[],"package":"invenio-previewer","purl":"pkg:pypi/invenio-previewer","source":"PYSEC-2019-26"}],"prev":{"headline":"Auth bypass in Discourse","id":"CVE-2019-1020018"},"products":["invenio-previewer"],"published":"2019-07-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Invenio"]},"summary":"An XSS vulnerability in the invenio-previewer library allows attackers to inject malicious scripts, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2019-1020019/"}