# CVE-2019-10206: Ansible password prompts could expose passwords

> Ansible CLI tools may expose passwords by expanding them from templates, allowing attackers to read sensitive credentials.

- **Severity:** Medium 6.4 (`CVSS:3.0/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Nov 2019
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2019-10206, DEBIAN-CVE-2019-10206, GHSA-cqmr-rcpr-cxh3, PYSEC-2019-145, RHSA-2019:2544, RHSA-2019:2545, SUSE-SU-2019:2274-1, UBUNTU-CVE-2019-10206

## What is CVE-2019-10206?

CVE-2019-10206 is a medium-severity vulnerability in Debian Debian Linux, published on 22 Nov 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

ansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x before 2.6.19, prompt passwords by expanding them from templates as they could contain special characters. Passwords should be wrapped to prevent templates trigger and exposing them.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2019-10206?

7 open source packages ship an affected version, including ansible. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | From 2.6.0 | 2.6.19, 2.7.13, 2.8.4 |
| `ansible` | PyPI | From 2.6.0 | 2.6.19 |
| `ansible` | PyPI | From 2.6.0 | 2.6.19 |
| `ansible` | PyPI | From 2.7.0 | 2.7.13 |
| `ansible` | PyPI | From 2.7.0 | 2.7.13 |
| `ansible` | PyPI | From 2.8.0 | 2.8.4 |
| `ansible` | PyPI | From 2.8.0 | 2.8.4 |
| `ansible` | Red Hat:ansible_engine:2.6::el7 | All versions | 0:2.6.19-1.el7ae |
| `ansible` | Red Hat:ansible_engine:2.7::el7 | All versions | 0:2.7.13-1.el7ae |
| `ansible` | SUSE:HPE Helion OpenStack 8 | All versions | 2.4.6.0-3.6.1 |
| `ansible` | SUSE:OpenStack Cloud 8 | All versions | 2.4.6.0-3.6.1 |
| `ansible` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 2.4.6.0-3.6.1 |

Products: Debian Debian Linux, Opensuse Backports Sle, Opensuse Leap, Redhat Ansible.

## How do I fix CVE-2019-10206?

Upgrade ansible to a fixed version for your release line: 2.6.19, 2.7.13 or 2.8.4.

## Is CVE-2019-10206 being exploited?

There is no known exploitation of CVE-2019-10206 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10206 and fix it if it is affected.

What it is: CVE-2019-10206 is a medium-severity vulnerability in Debian Debian Linux, published on 22 Nov 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-10206 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected from 2.6.0; fixed in 2.6.19, 2.7.13, 2.8.4
- ansible (PyPI): affected from 2.6.0; fixed in 2.6.19
- ansible (PyPI): affected from 2.6.0; fixed in 2.6.19
- ansible (PyPI): affected from 2.7.0; fixed in 2.7.13
- ansible (PyPI): affected from 2.7.0; fixed in 2.7.13
- ansible (PyPI): affected from 2.8.0; fixed in 2.8.4
- ansible (PyPI): affected from 2.8.0; fixed in 2.8.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10206/ (Markdown: https://insights.sbomify.com/CVE-2019-10206/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10206
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10206
- OSV: https://osv.dev/vulnerability/CVE-2019-10206

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10206/
Summaries are generated and may contain mistakes; the official description above is the record.
