{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-10215 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2019-10215 is a medium-severity cross-site scripting vulnerability in Red Hat bootstrap3-typeahead.js, published on 8 Oct 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-10215 and fix it if it is affected.\n\nWhat it is: CVE-2019-10215 is a medium-severity cross-site scripting vulnerability in Red Hat bootstrap3-typeahead.js, published on 8 Oct 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-10215 in the wild and no public exploit code.\n\nAffected product: Red Hat bootstrap3-typeahead.js. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-10215/ (Markdown: https://insights.sbomify.com/CVE-2019-10215/index.md)","id":"CVE-2019-10215","markdown":"https://insights.sbomify.com/CVE-2019-10215/index.md","name":"CVE-2019-10215","record":{"aliases":["SUSE-SU-2020:2606-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript typeahead library","requires_auth":"none","summary":"An attacker can execute arbitrary code in a user's browser via a cross-site scripting flaw in the highlighter function of the Bootstrap-3-Typeahead library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"bootstrap-3-typeahead","vendor":"bootstrap-3-typeahead_project"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Bootstrap-3-Typeahead after version 4.0.2 is vulnerable to a cross-site scripting flaw in the highlighter() function. An attacker could exploit this via user interaction to execute code in the user's browser.","ecosystems":["SUSE:Enterprise Storage 6"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site scripting in bootstrap3-typeahead.js","id":"CVE-2019-10215","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2019"},"n_packages":1,"n_references":3,"next":{"headline":"In ghostscript before version 9.50, the .buildfont1 procedure did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions.","id":"CVE-2019-10216"},"packages":[{"ecosystem":"SUSE:Enterprise Storage 6","fixed":["2.18.0-3.3.1"],"introduced":["0"],"last_affected":[],"package":"golang-github-prometheus-prometheus","purl":"pkg:rpm/suse/golang-github-prometheus-prometheus\u0026distro=SUSE%20Enterprise%20Storage%206","source":"SUSE-SU-2020:2606-1"}],"prev":{"headline":"containers/image library Insufficiently Protects Credentials","id":"CVE-2019-10214"},"products":["bootstrap3-typeahead.js"],"published":"2019-10-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Red Hat"]},"summary":"An attacker can execute arbitrary code in a user's browser via a cross-site scripting flaw in the highlighter function of the Bootstrap-3-Typeahead library.","url":"https://insights.sbomify.com/CVE-2019-10215/"}