CVE-2019-10217 Exposure of Sensitive Information to an Unauthorized Actor in ansible

Medium 5.7 Published Updated

Sensitive data in Ansible GCP modules is leaked in playbook output due to missing no_log settings, exposing credentials to anyone with log access.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2019-10217?

CVE-2019-10217 is a medium-severity vulnerability in Red Hat Ansible, published on 25 Nov 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A flaw was found in ansible 2.8.0 before 2.8.4. Fields managing sensitive data should be set as such by no_log feature. Some of these fields in GCP modules are not set properly. service_account_contents() which is common class for all gcp modules is not setting no_log to True. Any sensitive data managed by that function would be leak as an output when running ansible playbooks.

Weakness: CWE-200

Which versions are affected by CVE-2019-10217?

3 open source packages ship an affected version, including ansible. It affects 1 product.

PackageAffectedFixed in
ansible PyPIFrom 2.8.02.8.4
ansible PyPIFrom 2.8.0a12.8.4
ansible PyPIFrom 2.8.0a12.8.4

Products include Redhat Ansible.

How do I fix CVE-2019-10217?

Upgrade ansible to 2.8.4 or later.

Is CVE-2019-10217 being exploited?

There is no known exploitation of CVE-2019-10217 in the wild and no public exploit code.

Sources

Also known as ALPINE-CVE-2019-10217, DEBIAN-CVE-2019-10217, GHSA-p75j-wc34-527c, PYSEC-2019-3.

Is CVE-2019-10217 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free