{"answers":{"affected":"3 open source packages ship an affected version, including ansible. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-10217 in the wild and no public exploit code.","fix":"Upgrade ansible to 2.8.4 or later.","what":"CVE-2019-10217 is a medium-severity vulnerability in Red Hat Ansible, published on 25 Nov 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-10217 and fix it if it is affected.\n\nWhat it is: CVE-2019-10217 is a medium-severity vulnerability in Red Hat Ansible, published on 25 Nov 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-10217 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ansible (PyPI): affected from 2.8.0; fixed in 2.8.4\n- ansible (PyPI): affected from 2.8.0a1; fixed in 2.8.4\n- ansible (PyPI): affected from 2.8.0a1; fixed in 2.8.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-10217/ (Markdown: https://insights.sbomify.com/CVE-2019-10217/index.md)","id":"CVE-2019-10217","markdown":"https://insights.sbomify.com/CVE-2019-10217/index.md","name":"CVE-2019-10217","record":{"aliases":["ALPINE-CVE-2019-10217","DEBIAN-CVE-2019-10217","GHSA-p75j-wc34-527c","PYSEC-2019-3"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Ansible GCP modules","requires_auth":"low_privilege","summary":"Sensitive data in Ansible GCP modules is leaked in playbook output due to missing no_log settings, exposing credentials to anyone with log access.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"ansible","vendor":"redhat"}],"cvss":{"score":5.7,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"A flaw was found in ansible 2.8.0 before 2.8.4. Fields managing sensitive data should be set as such by no_log feature. Some of these fields in GCP modules are not set properly. service_account_contents() which is common class for all gcp modules is not setting no_log to True. Any sensitive data managed by that function would be leak as an output when running ansible playbooks.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Exposure of Sensitive Information to an Unauthorized Actor in ansible","id":"CVE-2019-10217","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"information_disclosure","year":"2019"},"n_packages":3,"n_references":5,"next":{"headline":"Path traversal in samba","id":"CVE-2019-10218"},"packages":[{"ecosystem":"PyPI","fixed":["2.8.4"],"introduced":["2.8.0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"PYSEC-2019-3"},{"ecosystem":"PyPI","fixed":["2.8.4"],"introduced":["2.8.0a1"],"last_affected":[],"package":"ansible","purl":null,"source":"GHSA-p75j-wc34-527c"},{"ecosystem":"PyPI","fixed":["2.8.4"],"introduced":["2.8.0a1"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-p75j-wc34-527c"}],"prev":{"headline":"In ghostscript before version 9.50, the .buildfont1 procedure did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions.","id":"CVE-2019-10216"},"products":["Ansible"],"published":"2019-11-25","related":[{"cvss_score":9.8,"headline":"Ansible Remote Code Execution","id":"CVE-2014-4657","kev_date_added":null,"published":"2020-02-20"},{"cvss_score":9.8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2014-4966","kev_date_added":null,"published":"2020-02-18"},{"cvss_score":9.8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2014-4967","kev_date_added":null,"published":"2020-02-18"},{"cvss_score":9.8,"headline":"Ansible Insertion of Sensitive Information into Log File vulnerability","id":"CVE-2017-7550","kev_date_added":null,"published":"2017-11-21"},{"cvss_score":8.8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2014-3498","kev_date_added":null,"published":"2017-06-08"},{"cvss_score":8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2017-7466","kev_date_added":null,"published":"2018-06-22"},{"cvss_score":7.8,"headline":"Ansible Sandbox Escape via Symlink Attack","id":"CVE-2015-6240","kev_date_added":null,"published":"2017-06-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Red Hat"]},"summary":"Sensitive data in Ansible GCP modules is leaked in playbook output due to missing no_log settings, exposing credentials to anyone with log access.","url":"https://insights.sbomify.com/CVE-2019-10217/"}