# CVE-2019-10217: Exposure of Sensitive Information to an Unauthorized Actor in ansible

> Sensitive data in Ansible GCP modules is leaked in playbook output due to missing no_log settings, exposing credentials to anyone with log access.

- **Severity:** Medium 5.7 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Nov 2019
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2019-10217, DEBIAN-CVE-2019-10217, GHSA-p75j-wc34-527c, PYSEC-2019-3

## What is CVE-2019-10217?

CVE-2019-10217 is a medium-severity vulnerability in Red Hat Ansible, published on 25 Nov 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A flaw was found in ansible 2.8.0 before 2.8.4. Fields managing sensitive data should be set as such by no_log feature. Some of these fields in GCP modules are not set properly. service_account_contents() which is common class for all gcp modules is not setting no_log to True. Any sensitive data managed by that function would be leak as an output when running ansible playbooks.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2019-10217?

3 open source packages ship an affected version, including ansible. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | From 2.8.0 | 2.8.4 |
| `ansible` | PyPI | From 2.8.0a1 | 2.8.4 |
| `ansible` | PyPI | From 2.8.0a1 | 2.8.4 |

Products: Redhat Ansible.

## How do I fix CVE-2019-10217?

Upgrade ansible to 2.8.4 or later.

## Is CVE-2019-10217 being exploited?

There is no known exploitation of CVE-2019-10217 in the wild and no public exploit code.

## Other vulnerabilities in Red Hat Ansible

- [CVE-2014-4657](https://insights.sbomify.com/CVE-2014-4657/): Ansible Remote Code Execution (critical 9.8)
- [CVE-2014-4966](https://insights.sbomify.com/CVE-2014-4966/): Ansible Arbitrary Code Execution (critical 9.8)
- [CVE-2014-4967](https://insights.sbomify.com/CVE-2014-4967/): Ansible Arbitrary Code Execution (critical 9.8)
- [CVE-2017-7550](https://insights.sbomify.com/CVE-2017-7550/): Ansible Insertion of Sensitive Information into Log File vulnerability (critical 9.8)
- [CVE-2014-3498](https://insights.sbomify.com/CVE-2014-3498/): Ansible Arbitrary Code Execution (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10217 and fix it if it is affected.

What it is: CVE-2019-10217 is a medium-severity vulnerability in Red Hat Ansible, published on 25 Nov 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-10217 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected from 2.8.0; fixed in 2.8.4
- ansible (PyPI): affected from 2.8.0a1; fixed in 2.8.4
- ansible (PyPI): affected from 2.8.0a1; fixed in 2.8.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10217/ (Markdown: https://insights.sbomify.com/CVE-2019-10217/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10217
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10217
- OSV: https://osv.dev/vulnerability/CVE-2019-10217

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10217/
Summaries are generated and may contain mistakes; the official description above is the record.
