# CVE-2019-10240: Cleartext Transmission of Sensitive Information, Inclusion of Functionality from Untrusted Control Sphere , and Download of Code Without Integrity Check in Eclipse hawkBit

> Attackers can compromise hawkBit builds via MITM attacks on insecure Maven dependencies, leading to malicious code execution in deployed instances.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Apr 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-jwqm-c9f2-2cq3

## What is CVE-2019-10240?

CVE-2019-10240 is a high-severity vulnerability in The Eclipse Foundation Eclipse hawkBit, published on 3 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Eclipse hawkBit versions prior to 0.3.0M2 resolved Maven build artifacts for the Vaadin based UI over HTTP instead of HTTPS. Any of these dependent artifacts could have been maliciously compromised by a MITM attack. Hence produced build artifacts of hawkBit might be infected.

Weakness: CWE-319 (Cleartext Transmission of Sensitive Information), CWE-829 (Inclusion of Functionality from Untrusted Control Sphere), CWE-494 (Download of Code Without Integrity Check)

## Which versions are affected by CVE-2019-10240?

20 open source packages ship an affected version, including org.eclipse.hawkbit:hawkbit-autoconfigure, org.eclipse.hawkbit:hawkbit-boot-starter and org.eclipse.hawkbit:hawkbit-boot-starter-ddi-api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.eclipse.hawkbit:hawkbit-autoconfigure` | Maven | All versions | 0.3.0M2 |
| `org.eclipse.hawkbit:hawkbit-autoconfigure` | Maven | All versions | 0.3.0M2 |
| `org.eclipse.hawkbit:hawkbit-boot-starter` | Maven | All versions | 0.3.0M2 |
| `org.eclipse.hawkbit:hawkbit-boot-starter` | Maven | All versions | 0.3.0M2 |
| `org.eclipse.hawkbit:hawkbit-boot-starter-ddi-api` | Maven | All versions | 0.3.0M2 |
| `org.eclipse.hawkbit:hawkbit-boot-starter-ddi-api` | Maven | All versions | 0.3.0M2 |
| `org.eclipse.hawkbit:hawkbit-boot-starter-dmf-api` | Maven | All versions | 0.3.0M2 |
| `org.eclipse.hawkbit:hawkbit-boot-starter-dmf-api` | Maven | All versions | 0.3.0M2 |
| `org.eclipse.hawkbit:hawkbit-boot-starter-mgmt-api` | Maven | All versions | 0.3.0M2 |
| `org.eclipse.hawkbit:hawkbit-boot-starter-mgmt-api` | Maven | All versions | 0.3.0M2 |
| `org.eclipse.hawkbit:hawkbit-boot-starter-mgmt-ui` | Maven | All versions | 0.3.0M2 |
| `org.eclipse.hawkbit:hawkbit-boot-starter-mgmt-ui` | Maven | All versions | 0.3.0M2 |
| `org.eclipse.hawkbit:hawkbit-parent` | Maven | All versions | 0.3.0M2 |
| `org.eclipse.hawkbit:hawkbit-parent` | Maven | All versions | 0.3.0M2 |
| `org.eclipse.hawkbit:hawkbit-starters` | Maven | All versions | 0.3.0M2 |
| `org.eclipse.hawkbit:hawkbit-starters` | Maven | All versions | 0.3.0M2 |
| `org.eclipse.hawkbit:hawkbit-ui` | Maven | All versions | 0.3.0M2 |
| `org.eclipse.hawkbit:hawkbit-ui` | Maven | All versions | 0.3.0M2 |
| `org.eclipse.hawkbit:hawkbit-update-server` | Maven | All versions | 0.3.0M2 |
| `org.eclipse.hawkbit:hawkbit-update-server` | Maven | All versions | 0.3.0M2 |

Products: Eclipse Hawkbit.

## How do I fix CVE-2019-10240?

Upgrade org.eclipse.hawkbit:hawkbit-autoconfigure to 0.3.0M2 or later.

## Is CVE-2019-10240 being exploited?

There is no known exploitation of CVE-2019-10240 in the wild and no public exploit code.

## Other vulnerabilities in The Eclipse Foundation Eclipse hawkBit

- [CVE-2020-27219](https://insights.sbomify.com/CVE-2020-27219/): Cross-site Scripting in Eclipse Hawkbit (medium 6.1)
- [CVE-2026-16454](https://insights.sbomify.com/CVE-2026-16454/): Privilege Escalation in Eclipse hawkBit DDI allows Tenant-Isolated Firmware Exfiltration (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10240 and fix it if it is affected.

What it is: CVE-2019-10240 is a high-severity vulnerability in The Eclipse Foundation Eclipse hawkBit, published on 3 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10240 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.eclipse.hawkbit:hawkbit-autoconfigure (Maven): affected all versions; fixed in 0.3.0M2
- org.eclipse.hawkbit:hawkbit-autoconfigure (Maven): affected all versions; fixed in 0.3.0M2
- org.eclipse.hawkbit:hawkbit-boot-starter (Maven): affected all versions; fixed in 0.3.0M2
- org.eclipse.hawkbit:hawkbit-boot-starter (Maven): affected all versions; fixed in 0.3.0M2
- org.eclipse.hawkbit:hawkbit-boot-starter-ddi-api (Maven): affected all versions; fixed in 0.3.0M2
- org.eclipse.hawkbit:hawkbit-boot-starter-ddi-api (Maven): affected all versions; fixed in 0.3.0M2
- org.eclipse.hawkbit:hawkbit-boot-starter-dmf-api (Maven): affected all versions; fixed in 0.3.0M2
- org.eclipse.hawkbit:hawkbit-boot-starter-dmf-api (Maven): affected all versions; fixed in 0.3.0M2
- org.eclipse.hawkbit:hawkbit-boot-starter-mgmt-api (Maven): affected all versions; fixed in 0.3.0M2
- org.eclipse.hawkbit:hawkbit-boot-starter-mgmt-api (Maven): affected all versions; fixed in 0.3.0M2
- org.eclipse.hawkbit:hawkbit-boot-starter-mgmt-ui (Maven): affected all versions; fixed in 0.3.0M2
- org.eclipse.hawkbit:hawkbit-boot-starter-mgmt-ui (Maven): affected all versions; fixed in 0.3.0M2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10240/ (Markdown: https://insights.sbomify.com/CVE-2019-10240/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10240
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10240
- OSV: https://osv.dev/vulnerability/CVE-2019-10240

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10240/
Summaries are generated and may contain mistakes; the official description above is the record.
