# CVE-2019-10247: Installation information leak in Eclipse Jetty

> Eclipse Jetty reveals configured directory paths in 404 error pages, allowing attackers to gather sensitive filesystem information.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Apr 2019
- **Updated:** 4 Aug 2024
- **Also known as:** CLEANSTART-2026-OC64545, DEBIAN-CVE-2019-10247, GHSA-xc67-hjx6-cgg6, UBUNTU-CVE-2019-10247

## What is CVE-2019-10247?

CVE-2019-10247 is a medium-severity vulnerability in Debian Debian Linux, published on 22 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Eclipse Jetty version 7.x, 8.x, 9.2.27 and older, 9.3.26 and older, and 9.4.16 and older, the server running on any OS and Jetty version combination will reveal the configured fully qualified directory base resource location on the output of the 404 error for not finding a Context that matches the requested path. The default server behavior on jetty-distribution and jetty-home will include at the end of the Handler tree a DefaultHandler, which is responsible for reporting this 404 error, it presents the various configured contexts as HTML for users to click through to. This produced HTML includes output that contains the configured fully qualified directory base resource location for each context.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor), CWE-213 (Exposure of Sensitive Information Due to Incompatible Policies)

## Which versions are affected by CVE-2019-10247?

6 open source packages ship an affected version, including org.eclipse.jetty:jetty-server. It affects 26 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.eclipse.jetty:jetty-server` | Maven | From 7.0.0 | 9.2.28.v20190418 |
| `org.eclipse.jetty:jetty-server` | Maven | From 7.0.0 | 9.2.28.v20190418 |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.3.0 | 9.3.27.v20190418 |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.3.0 | 9.3.27.v20190418 |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.4.0 | 9.4.17.v20190418 |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.4.0 | 9.4.17.v20190418 |

Products: Debian Debian Linux, Eclipse Jetty, Netapp Element, Netapp Oncommand System Manager, Netapp Snap Creator Framework, Netapp Snapcenter, Netapp Snapmanager, Netapp Storage Replication Adapter for Clustered Data Ontap, Netapp Storage Services Connector, Netapp Vasa Provider for Clustered Data Ontap, Netapp Virtual Storage Console, Oracle Autovue, Oracle Communications Analytics, Oracle Communications Element Manager, Oracle Communications Services Gatekeeper, Oracle Communications Session Report Manager, Oracle Communications Session Route Manager, Oracle Data Integrator, Oracle Endeca Information Discovery Integrator, Oracle Enterprise Manager Base Platform and 6 more.

## How do I fix CVE-2019-10247?

Upgrade org.eclipse.jetty:jetty-server to a fixed version for your release line: 9.2.28.v20190418, 9.3.27.v20190418 or 9.4.17.v20190418.

## Is CVE-2019-10247 being exploited?

There is no known exploitation of CVE-2019-10247 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10247 and fix it if it is affected.

What it is: CVE-2019-10247 is a medium-severity vulnerability in Debian Debian Linux, published on 22 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10247 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.eclipse.jetty:jetty-server (Maven): affected from 7.0.0; fixed in 9.2.28.v20190418
- org.eclipse.jetty:jetty-server (Maven): affected from 7.0.0; fixed in 9.2.28.v20190418
- org.eclipse.jetty:jetty-server (Maven): affected from 9.3.0; fixed in 9.3.27.v20190418
- org.eclipse.jetty:jetty-server (Maven): affected from 9.3.0; fixed in 9.3.27.v20190418
- org.eclipse.jetty:jetty-server (Maven): affected from 9.4.0; fixed in 9.4.17.v20190418
- org.eclipse.jetty:jetty-server (Maven): affected from 9.4.0; fixed in 9.4.17.v20190418

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10247/ (Markdown: https://insights.sbomify.com/CVE-2019-10247/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10247
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10247
- OSV: https://osv.dev/vulnerability/CVE-2019-10247

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10247/
Summaries are generated and may contain mistakes; the official description above is the record.
