# CVE-2019-10248: Eclipse Vorto resolved Maven build artifacts for the Xtext project over HTTP instead of HTTPS

> Attackers can compromise build artifacts via MITM during Maven dependency resolution, leading to infected software builds.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Apr 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-fg2q-v428-2gph

## What is CVE-2019-10248?

CVE-2019-10248 is a high-severity vulnerability in The Eclipse Foundation Eclipse Vorto, published on 22 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Eclipse Vorto versions prior to 0.11 resolved Maven build artifacts for the Xtext project over HTTP instead of HTTPS. Any of these dependent artifacts could have been maliciously compromised by a MITM attack. Hence produced build artifacts of Vorto might be infected.

Weakness: CWE-669 (Incorrect Resource Transfer Between Spheres), CWE-829 (Inclusion of Functionality from Untrusted Control Sphere), CWE-494 (Download of Code Without Integrity Check)

## Which versions are affected by CVE-2019-10248?

2 open source packages ship an affected version, including org.eclipse.vorto:org.eclipse.vorto.core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.eclipse.vorto:org.eclipse.vorto.core` | Maven | All versions | 0.11.0 |
| `org.eclipse.vorto:org.eclipse.vorto.core` | Maven | All versions | 0.11.0 |

Products: Eclipse Vorto.

## How do I fix CVE-2019-10248?

Upgrade org.eclipse.vorto:org.eclipse.vorto.core to 0.11.0 or later.

## Is CVE-2019-10248 being exploited?

There is no known exploitation of CVE-2019-10248 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10248 and fix it if it is affected.

What it is: CVE-2019-10248 is a high-severity vulnerability in The Eclipse Foundation Eclipse Vorto, published on 22 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10248 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.eclipse.vorto:org.eclipse.vorto.core (Maven): affected all versions; fixed in 0.11.0
- org.eclipse.vorto:org.eclipse.vorto.core (Maven): affected all versions; fixed in 0.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10248/ (Markdown: https://insights.sbomify.com/CVE-2019-10248/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10248
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10248
- OSV: https://osv.dev/vulnerability/CVE-2019-10248

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10248/
Summaries are generated and may contain mistakes; the official description above is the record.
