# CVE-2019-10249: Potentially compromised builds

> Attackers could compromise Eclipse Xtext artifacts during HTTP-based builds, potentially leading to code execution in dependent applications.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 May 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-rfj2-4g26-7jw5

## What is CVE-2019-10249?

CVE-2019-10249 is a high-severity vulnerability in The Eclipse Foundation Eclipse Xtext, published on 6 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

All Xtext & Xtend versions prior to 2.18.0 were built using HTTP instead of HTTPS file transfer and thus the built artifacts may have been compromised.

Weakness: CWE-116 (Improper Encoding or Escaping of Output), CWE-829 (Inclusion of Functionality from Untrusted Control Sphere), CWE-494 (Download of Code Without Integrity Check)

## Which versions are affected by CVE-2019-10249?

4 open source packages ship an affected version, including org.eclipse.xtext:org.eclipse.xtext and org.eclipse.xtend:org.eclipse.xtend.core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.eclipse.xtext:org.eclipse.xtext` | Maven | All versions | 2.18.0 |
| `org.eclipse.xtext:org.eclipse.xtext` | Maven | All versions | 2.18.0 |
| `org.eclipse.xtend:org.eclipse.xtend.core` | Maven | All versions | 2.18.0 |
| `org.eclipse.xtend:org.eclipse.xtend.core` | Maven | All versions | 2.18.0 |

Products: Eclipse Xtend, Eclipse Xtext.

## How do I fix CVE-2019-10249?

Upgrade org.eclipse.xtext:org.eclipse.xtext to 2.18.0 or later.

## Is CVE-2019-10249 being exploited?

There is no known exploitation of CVE-2019-10249 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10249 and fix it if it is affected.

What it is: CVE-2019-10249 is a high-severity vulnerability in The Eclipse Foundation Eclipse Xtext, published on 6 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10249 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.eclipse.xtext:org.eclipse.xtext (Maven): affected all versions; fixed in 2.18.0
- org.eclipse.xtext:org.eclipse.xtext (Maven): affected all versions; fixed in 2.18.0
- org.eclipse.xtend:org.eclipse.xtend.core (Maven): affected all versions; fixed in 2.18.0
- org.eclipse.xtend:org.eclipse.xtend.core (Maven): affected all versions; fixed in 2.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10249/ (Markdown: https://insights.sbomify.com/CVE-2019-10249/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10249
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10249
- OSV: https://osv.dev/vulnerability/CVE-2019-10249

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10249/
Summaries are generated and may contain mistakes; the official description above is the record.
