# CVE-2019-10306: Sandbox bypass in ontrack Jenkins Plugin

> Attackers with control over DSL definitions can execute arbitrary code on the Jenkins master JVM via a sandbox bypass in the ontrack plugin.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Apr 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-qw28-g63m-jxqv

## What is CVE-2019-10306?

CVE-2019-10306 is a critical code injection vulnerability in Jenkins ontrack Plugin, published on 18 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A sandbox bypass vulnerability in Jenkins ontrack Plugin 3.4 and earlier allowed attackers with control over ontrack DSL definitions to execute arbitrary code on the Jenkins master JVM.

## Which versions are affected by CVE-2019-10306?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:ontrack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:ontrack` | Maven | All versions | 3.4.1 |
| `org.jenkins-ci.plugins:ontrack` | Maven | All versions | 3.4.1 |

Products: Jenkins Ontrack.

## How do I fix CVE-2019-10306?

Upgrade org.jenkins-ci.plugins:ontrack to 3.4.1 or later.

## Is CVE-2019-10306 being exploited?

There is no known exploitation of CVE-2019-10306 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins ontrack Plugin

- [CVE-2022-34192](https://insights.sbomify.com/CVE-2022-34192/): Cross-site Scripting in Jenkins ontrack Jenkins Plugin (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10306 and fix it if it is affected.

What it is: CVE-2019-10306 is a critical code injection vulnerability in Jenkins ontrack Plugin, published on 18 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10306 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:ontrack (Maven): affected all versions; fixed in 3.4.1
- org.jenkins-ci.plugins:ontrack (Maven): affected all versions; fixed in 3.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10306/ (Markdown: https://insights.sbomify.com/CVE-2019-10306/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10306
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10306
- OSV: https://osv.dev/vulnerability/CVE-2019-10306

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10306/
Summaries are generated and may contain mistakes; the official description above is the record.
