{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:ansible-tower. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-10310 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:ansible-tower to 0.9.2 or later.","what":"CVE-2019-10310 is a high-severity vulnerability in Jenkins Ansible Tower Plugin, published on 30 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-10310 and fix it if it is affected.\n\nWhat it is: CVE-2019-10310 is a high-severity vulnerability in Jenkins Ansible Tower Plugin, published on 30 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-10310 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:ansible-tower (Maven): affected all versions; fixed in 0.9.2\n- org.jenkins-ci.plugins:ansible-tower (Maven): affected all versions; fixed in 0.9.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-10310/ (Markdown: https://insights.sbomify.com/CVE-2019-10310/index.md)","id":"CVE-2019-10310","markdown":"https://insights.sbomify.com/CVE-2019-10310/index.md","name":"CVE-2019-10310","record":{"aliases":["GHSA-vrvm-459q-j824"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Ansible Plugin","requires_auth":"none","summary":"Attackers can exploit CSRF to force Jenkins to connect to malicious URLs, potentially capturing stored credentials via the Ansible Tower plugin.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"ansible_tower","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"A cross-site request forgery vulnerability in Jenkins Ansible Tower Plugin 0.9.1 and earlier in the TowerInstallation.TowerInstallationDescriptor#doTestTowerConnection form validation method allowed attackers permission to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Ansible Tower Plugin cross-site request forgery vulnerability","id":"CVE-2019-10310","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2019"},"n_packages":2,"n_references":4,"next":{"headline":"Jenkins Ansible Tower Plugin missing permission check","id":"CVE-2019-10311"},"packages":[{"ecosystem":"Maven","fixed":["0.9.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:ansible-tower","purl":null,"source":"GHSA-vrvm-459q-j824"},{"ecosystem":"Maven","fixed":["0.9.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:ansible-tower","purl":"pkg:maven/org.jenkins-ci.plugins/ansible-tower","source":"GHSA-vrvm-459q-j824"}],"prev":{"headline":"Jenkins Self-Organizing Swarm Plug-in Modules Plugin XXE vulnerability via UDP broadcast response","id":"CVE-2019-10309"},"products":["Jenkins Ansible Tower Plugin"],"published":"2019-04-30","related":[{"cvss_score":8.8,"headline":"Jenkins Ansible Tower Plugin missing permission check","id":"CVE-2019-10311","kev_date_added":null,"published":"2019-04-30"},{"cvss_score":4.3,"headline":"Missing permission check in Jenkins Ansible Tower Plugin","id":"CVE-2019-10312","kev_date_added":null,"published":"2019-04-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"Attackers can exploit CSRF to force Jenkins to connect to malicious URLs, potentially capturing stored credentials via the Ansible Tower plugin.","url":"https://insights.sbomify.com/CVE-2019-10310/"}