# CVE-2019-10312: Missing permission check in Jenkins Ansible Tower Plugin

> Attackers with read permissions can enumerate stored credential IDs due to missing permission checks in the Jenkins Ansible Tower Plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Apr 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-7mvg-cx9c-r6jm

## What is CVE-2019-10312?

CVE-2019-10312 is a medium-severity missing authorization vulnerability in Jenkins Ansible Tower Plugin, published on 30 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A missing permission check in Jenkins Ansible Tower Plugin 0.9.1 and earlier in the TowerInstallation.TowerInstallationDescriptor#doFillTowerCredentialsIdItems method allowed attackers with Overall/Read permission to enumerate credentials ID of credentials stored in Jenkins.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2019-10312?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:ansible-tower. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:ansible-tower` | Maven | All versions | 0.9.2 |
| `org.jenkins-ci.plugins:ansible-tower` | Maven | All versions | 0.9.2 |

Products: Jenkins Ansible Tower.

## How do I fix CVE-2019-10312?

Upgrade org.jenkins-ci.plugins:ansible-tower to 0.9.2 or later.

## Is CVE-2019-10312 being exploited?

There is no known exploitation of CVE-2019-10312 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Ansible Tower Plugin

- [CVE-2019-10310](https://insights.sbomify.com/CVE-2019-10310/): Jenkins Ansible Tower Plugin cross-site request forgery vulnerability (high 8.8)
- [CVE-2019-10311](https://insights.sbomify.com/CVE-2019-10311/): Jenkins Ansible Tower Plugin missing permission check (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10312 and fix it if it is affected.

What it is: CVE-2019-10312 is a medium-severity missing authorization vulnerability in Jenkins Ansible Tower Plugin, published on 30 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10312 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:ansible-tower (Maven): affected all versions; fixed in 0.9.2
- org.jenkins-ci.plugins:ansible-tower (Maven): affected all versions; fixed in 0.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10312/ (Markdown: https://insights.sbomify.com/CVE-2019-10312/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10312
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10312
- OSV: https://osv.dev/vulnerability/CVE-2019-10312

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10312/
Summaries are generated and may contain mistakes; the official description above is the record.
