{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:github-oauth. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-10315 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:github-oauth to 0.32 or later.","what":"CVE-2019-10315 is a high-severity vulnerability in Jenkins GitHub Authentication Plugin, published on 30 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-10315 and fix it if it is affected.\n\nWhat it is: CVE-2019-10315 is a high-severity vulnerability in Jenkins GitHub Authentication Plugin, published on 30 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-10315 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:github-oauth (Maven): affected all versions; fixed in 0.32\n- org.jenkins-ci.plugins:github-oauth (Maven): affected all versions; fixed in 0.32\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-10315/ (Markdown: https://insights.sbomify.com/CVE-2019-10315/index.md)","id":"CVE-2019-10315","markdown":"https://insights.sbomify.com/CVE-2019-10315/index.md","name":"CVE-2019-10315","record":{"aliases":["GHSA-phwv-crgp-9r69"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins GitHub Auth Plugin","requires_auth":"none","summary":"Attackers can perform CSRF attacks against Jenkins users by exploiting missing OAuth state validation in the GitHub Authentication Plugin.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"github_authentication","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Jenkins GitHub Authentication Plugin 0.31 and earlier did not use the state parameter of OAuth to prevent CSRF.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins GitHub Authentication Plugin Cross-Site Request Forgery vulnerability","id":"CVE-2019-10315","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2019"},"n_packages":2,"n_references":3,"next":{"headline":"Jenkins Aqua MicroScanner Plugin stored credentials in plain text","id":"CVE-2019-10316"},"packages":[{"ecosystem":"Maven","fixed":["0.32"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:github-oauth","purl":null,"source":"GHSA-phwv-crgp-9r69"},{"ecosystem":"Maven","fixed":["0.32"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:github-oauth","purl":"pkg:maven/org.jenkins-ci.plugins/github-oauth","source":"GHSA-phwv-crgp-9r69"}],"prev":{"headline":"Jenkins Koji Plugin globally and unconditionally disables SSL/TLS certificate validation","id":"CVE-2019-10314"},"products":["Jenkins GitHub Authentication Plugin"],"published":"2019-04-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"Attackers can perform CSRF attacks against Jenkins users by exploiting missing OAuth state validation in the GitHub Authentication Plugin.","url":"https://insights.sbomify.com/CVE-2019-10315/"}