# CVE-2019-10315: Jenkins GitHub Authentication Plugin Cross-Site Request Forgery vulnerability

> Attackers can perform CSRF attacks against Jenkins users by exploiting missing OAuth state validation in the GitHub Authentication Plugin.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Apr 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-phwv-crgp-9r69

## What is CVE-2019-10315?

CVE-2019-10315 is a high-severity vulnerability in Jenkins GitHub Authentication Plugin, published on 30 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Jenkins GitHub Authentication Plugin 0.31 and earlier did not use the state parameter of OAuth to prevent CSRF.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2019-10315?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:github-oauth. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:github-oauth` | Maven | All versions | 0.32 |
| `org.jenkins-ci.plugins:github-oauth` | Maven | All versions | 0.32 |

Products: Jenkins Github Authentication.

## How do I fix CVE-2019-10315?

Upgrade org.jenkins-ci.plugins:github-oauth to 0.32 or later.

## Is CVE-2019-10315 being exploited?

There is no known exploitation of CVE-2019-10315 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10315 and fix it if it is affected.

What it is: CVE-2019-10315 is a high-severity vulnerability in Jenkins GitHub Authentication Plugin, published on 30 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-10315 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:github-oauth (Maven): affected all versions; fixed in 0.32
- org.jenkins-ci.plugins:github-oauth (Maven): affected all versions; fixed in 0.32

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10315/ (Markdown: https://insights.sbomify.com/CVE-2019-10315/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10315
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10315
- OSV: https://osv.dev/vulnerability/CVE-2019-10315

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10315/
Summaries are generated and may contain mistakes; the official description above is the record.
