# CVE-2019-10320: Insertion of Sensitive Information into Externally-Accessible File or Directory in Jenkins Credentials Plugin

> Users with credential creation permissions can confirm file existence and read PKCS#12 certificate contents on the Jenkins master.

- **Severity:** Medium 4.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 May 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-xm94-9jw8-p6hw

## What is CVE-2019-10320?

CVE-2019-10320 is a medium-severity vulnerability in Jenkins Credentials Plugin, published on 21 May 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Credentials Plugin 2.1.18 and earlier allowed users with permission to create or update credentials to confirm the existence of files on the Jenkins master with an attacker-specified path, and obtain the certificate content of files containing a PKCS#12 certificate.

Weakness: CWE-538 (Insertion of Sensitive Information into Externally-Accessible File or Directory)

## Which versions are affected by CVE-2019-10320?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:credentials. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:credentials` | Maven | All versions | 2.1.19 |
| `org.jenkins-ci.plugins:credentials` | Maven | All versions | 2.1.19 |

Products: Jenkins Credentials.

## How do I fix CVE-2019-10320?

Upgrade org.jenkins-ci.plugins:credentials to 2.1.19 or later.

## Is CVE-2019-10320 being exploited?

There is no known exploitation of CVE-2019-10320 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Credentials Plugin

- [CVE-2024-47805](https://insights.sbomify.com/CVE-2024-47805/): Jenkins Credentials plugin reveals encrypted values of credentials to users with Extended Read permission (high 7.5)
- [CVE-2021-21648](https://insights.sbomify.com/CVE-2021-21648/): Cross-Site Request Forgery in Jenkins Credentials Plugin (medium 6.1)
- [CVE-2022-29036](https://insights.sbomify.com/CVE-2022-29036/): Cross-site Scripting in Jenkins Credentials Plugin (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10320 and fix it if it is affected.

What it is: CVE-2019-10320 is a medium-severity vulnerability in Jenkins Credentials Plugin, published on 21 May 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10320 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:credentials (Maven): affected all versions; fixed in 2.1.19
- org.jenkins-ci.plugins:credentials (Maven): affected all versions; fixed in 2.1.19

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10320/ (Markdown: https://insights.sbomify.com/CVE-2019-10320/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10320
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10320
- OSV: https://osv.dev/vulnerability/CVE-2019-10320

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10320/
Summaries are generated and may contain mistakes; the official description above is the record.
