{"answers":{"affected":"2 open source packages ship an affected version, including io.jenkins.plugins:warnings-ng. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-10325 in the wild and no public exploit code.","fix":"Upgrade io.jenkins.plugins:warnings-ng to 5.1.0 or later.","what":"CVE-2019-10325 is a medium-severity cross-site scripting vulnerability in Jenkins Warnings NG Plugin, published on 31 May 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-10325 and fix it if it is affected.\n\nWhat it is: CVE-2019-10325 is a medium-severity cross-site scripting vulnerability in Jenkins Warnings NG Plugin, published on 31 May 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-10325 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.jenkins.plugins:warnings-ng (Maven): affected all versions; fixed in 5.1.0\n- io.jenkins.plugins:warnings-ng (Maven): affected all versions; fixed in 5.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-10325/ (Markdown: https://insights.sbomify.com/CVE-2019-10325/index.md)","id":"CVE-2019-10325","markdown":"https://insights.sbomify.com/CVE-2019-10325/index.md","name":"CVE-2019-10325","record":{"aliases":["GHSA-wrr5-p265-7252"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Warnings NG Plugin","requires_auth":"low_privilege","summary":"An attacker with Job/Configure permission can inject arbitrary JavaScript into build overview pages via the Jenkins Warnings NG Plugin.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"warnings_next_generation","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A cross-site scripting vulnerability in Jenkins Warnings NG Plugin 5.0.0 and earlier allowed attacker with Job/Configure permission to inject arbitrary JavaScript in build overview pages.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Warnings NG Plugin Cross-site scripting vulnerability","id":"CVE-2019-10325","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":2,"n_references":3,"next":{"headline":"Jenkins Warnings NG Plugin cross-site request forgery vulnerability","id":"CVE-2019-10326"},"packages":[{"ecosystem":"Maven","fixed":["5.1.0"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:warnings-ng","purl":null,"source":"GHSA-wrr5-p265-7252"},{"ecosystem":"Maven","fixed":["5.1.0"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:warnings-ng","purl":"pkg:maven/io.jenkins.plugins/warnings-ng","source":"GHSA-wrr5-p265-7252"}],"prev":{"headline":"Cross-site request forgery vulnerability in Jenkins Artifactory Plugin","id":"CVE-2019-10324"},"products":["Jenkins Warnings NG Plugin"],"published":"2019-05-31","related":[{"cvss_score":8.8,"headline":"Jenkins Warnings Next Generation Plugin cross-site request forgery vulnerability","id":"CVE-2019-1003008","kev_date_added":null,"published":"2019-02-06"},{"cvss_score":8.1,"headline":"Path Traversal in Jenkins Warnings Next Generation Plugin","id":"CVE-2022-23107","kev_date_added":null,"published":"2022-01-12"},{"cvss_score":6.1,"headline":"XSS vulnerability in Jenkins Warnings Next Generation Plugin","id":"CVE-2019-1003023","kev_date_added":null,"published":"2019-02-06"},{"cvss_score":4.3,"headline":"Missing permission checks in Jenkins Warnings Next Generation Plugin allow listing workspace contents","id":"CVE-2021-21626","kev_date_added":null,"published":"2021-03-18"},{"cvss_score":4.3,"headline":"Jenkins Warnings NG Plugin cross-site request forgery vulnerability","id":"CVE-2019-10326","kev_date_added":null,"published":"2019-05-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"An attacker with Job/Configure permission can inject arbitrary JavaScript into build overview pages via the Jenkins Warnings NG Plugin.","url":"https://insights.sbomify.com/CVE-2019-10325/"}