# CVE-2019-10326: Jenkins Warnings NG Plugin cross-site request forgery vulnerability

> Attackers can reset warning counts for future builds via cross-site request forgery in the Jenkins Warnings NG Plugin.

- **Severity:** Medium 4.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 May 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-px35-882c-47hw

## What is CVE-2019-10326?

CVE-2019-10326 is a medium-severity vulnerability in Jenkins Warnings NG Plugin, published on 31 May 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross-site request forgery vulnerability in Jenkins Warnings NG Plugin 5.0.0 and earlier allowed attackers to reset warning counts for future builds.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2019-10326?

2 open source packages ship an affected version, including io.jenkins.plugins:warnings-ng. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.jenkins.plugins:warnings-ng` | Maven | All versions | 5.1.0 |
| `io.jenkins.plugins:warnings-ng` | Maven | All versions | 5.1.0 |

Products: Jenkins Warnings Next Generation.

## How do I fix CVE-2019-10326?

Upgrade io.jenkins.plugins:warnings-ng to 5.1.0 or later.

## Is CVE-2019-10326 being exploited?

There is no known exploitation of CVE-2019-10326 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Warnings NG Plugin

- [CVE-2019-1003008](https://insights.sbomify.com/CVE-2019-1003008/): Jenkins Warnings Next Generation Plugin cross-site request forgery vulnerability (high 8.8)
- [CVE-2022-23107](https://insights.sbomify.com/CVE-2022-23107/): Path Traversal in Jenkins Warnings Next Generation Plugin (high 8.1)
- [CVE-2019-1003023](https://insights.sbomify.com/CVE-2019-1003023/): XSS vulnerability in Jenkins Warnings Next Generation Plugin (medium 6.1)
- [CVE-2019-10325](https://insights.sbomify.com/CVE-2019-10325/): Jenkins Warnings NG Plugin Cross-site scripting vulnerability (medium 5.4)
- [CVE-2021-21626](https://insights.sbomify.com/CVE-2021-21626/): Missing permission checks in Jenkins Warnings Next Generation Plugin allow listing workspace contents (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10326 and fix it if it is affected.

What it is: CVE-2019-10326 is a medium-severity vulnerability in Jenkins Warnings NG Plugin, published on 31 May 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-10326 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.jenkins.plugins:warnings-ng (Maven): affected all versions; fixed in 5.1.0
- io.jenkins.plugins:warnings-ng (Maven): affected all versions; fixed in 5.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10326/ (Markdown: https://insights.sbomify.com/CVE-2019-10326/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10326
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10326
- OSV: https://osv.dev/vulnerability/CVE-2019-10326

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10326/
Summaries are generated and may contain mistakes; the official description above is the record.
