# CVE-2019-10327: XML External Entity processing vulnerability in Pipeline Maven Integration Jenkins Plugin

> Attackers controlling agent temp files can trigger XXE in Jenkins Maven plugin to extract secrets, cause SSRF, or denial of service.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 May 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-6755-jgp4-8q7h

## What is CVE-2019-10327?

CVE-2019-10327 is a high-severity vulnerability in Jenkins Pipeline Maven Integration Plugin, published on 31 May 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An XML external entities (XXE) vulnerability in Jenkins Pipeline Maven Integration Plugin 1.7.0 and earlier allowed attackers able to control a temporary directory's content on the agent running the Maven build to have Jenkins parse a maliciously crafted XML file that uses external entities for extraction of secrets from the Jenkins master, server-side request forgery, or denial-of-service attacks.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2019-10327?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:pipeline-maven. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:pipeline-maven` | Maven | All versions | 3.7.1 |
| `org.jenkins-ci.plugins:pipeline-maven` | Maven | All versions | 3.7.1 |

Products: Jenkins Pipeline Maven Integration.

## How do I fix CVE-2019-10327?

Upgrade org.jenkins-ci.plugins:pipeline-maven to 3.7.1 or later.

## Is CVE-2019-10327 being exploited?

There is no known exploitation of CVE-2019-10327 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Pipeline Maven Integration Plugin

- [CVE-2020-2233](https://insights.sbomify.com/CVE-2020-2233/): Missing permission check in Jenkins Pipeline Maven Integration Plugin allows enumerating credentials IDs (medium 6.5)
- [CVE-2020-2234](https://insights.sbomify.com/CVE-2020-2234/): Missing permission check in Jenkins Pipeline Maven Integration Plugin allow capturing credentials (medium 6.5)
- [CVE-2020-2235](https://insights.sbomify.com/CVE-2020-2235/): CSRF vulnerability in Jenkins Pipeline Maven Integration Plugin allow capturing credentials (medium 6.5)
- [CVE-2020-2256](https://insights.sbomify.com/CVE-2020-2256/): Stored XSS vulnerability in Pipeline Maven Integration Plugin via unescaped display name (medium 5.4)
- [CVE-2023-41934](https://insights.sbomify.com/CVE-2023-41934/): Improper masking of credentials in Jenkins Pipeline Maven Integration Plugin (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10327 and fix it if it is affected.

What it is: CVE-2019-10327 is a high-severity vulnerability in Jenkins Pipeline Maven Integration Plugin, published on 31 May 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10327 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:pipeline-maven (Maven): affected all versions; fixed in 3.7.1
- org.jenkins-ci.plugins:pipeline-maven (Maven): affected all versions; fixed in 3.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10327/ (Markdown: https://insights.sbomify.com/CVE-2019-10327/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10327
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10327
- OSV: https://osv.dev/vulnerability/CVE-2019-10327

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10327/
Summaries are generated and may contain mistakes; the official description above is the record.
