{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:workflow-remote-loader. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-10328 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:workflow-remote-loader to 1.5 or later.","what":"CVE-2019-10328 is a critical vulnerability in Jenkins Pipeline Remote Loader Plugin, published on 31 May 2019. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-10328 and fix it if it is affected.\n\nWhat it is: CVE-2019-10328 is a critical vulnerability in Jenkins Pipeline Remote Loader Plugin, published on 31 May 2019. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-10328 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:workflow-remote-loader (Maven): affected all versions; fixed in 1.5\n- org.jenkins-ci.plugins:workflow-remote-loader (Maven): affected all versions; fixed in 1.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-10328/ (Markdown: https://insights.sbomify.com/CVE-2019-10328/index.md)","id":"CVE-2019-10328","markdown":"https://insights.sbomify.com/CVE-2019-10328/index.md","name":"CVE-2019-10328","record":{"aliases":["GHSA-v558-fhw2-v46w","RHBA-2019:2921"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Pipeline Plugin","requires_auth":"low_privilege","summary":"Attackers can bypass Jenkins script security sandbox to execute arbitrary code via the Pipeline Remote Loader Plugin.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"pipeline_remote_loader","vendor":"jenkins"}],"cvss":{"score":9.9,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-693","name":"Protection Mechanism Failure"}],"description":"Jenkins Pipeline Remote Loader Plugin 1.4 and earlier provided a custom whitelist for script security that allowed attackers to invoke arbitrary methods, bypassing typical sandbox protection.","ecosystems":["Maven","Red Hat:openshift:4.2::el7"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Unsafe entry in Script Security list of approved signatures in Pipeline Remote Loader Plugin","id":"CVE-2019-10328","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"security_feature_bypass","year":"2019"},"n_packages":3,"n_references":5,"next":{"headline":"Plaintext password storage in Jenkins InfluxDB Plugin","id":"CVE-2019-10329"},"packages":[{"ecosystem":"Maven","fixed":["1.5"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:workflow-remote-loader","purl":null,"source":"GHSA-v558-fhw2-v46w"},{"ecosystem":"Maven","fixed":["1.5"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:workflow-remote-loader","purl":"pkg:maven/org.jenkins-ci.plugins/workflow-remote-loader","source":"GHSA-v558-fhw2-v46w"},{"ecosystem":"Red Hat:openshift:4.2::el7","fixed":["0:4.2.1568997376-1.el7"],"introduced":["0"],"last_affected":[],"package":"jenkins-2-plugins","purl":"pkg:rpm/redhat/jenkins-2-plugins","source":"RHBA-2019:2921"}],"prev":{"headline":"XML External Entity processing vulnerability in Pipeline Maven Integration Jenkins Plugin","id":"CVE-2019-10327"},"products":["Jenkins Pipeline Remote Loader Plugin"],"published":"2019-05-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHBA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"Attackers can bypass Jenkins script security sandbox to execute arbitrary code via the Pipeline Remote Loader Plugin.","url":"https://insights.sbomify.com/CVE-2019-10328/"}