# CVE-2019-10328: Unsafe entry in Script Security list of approved signatures in Pipeline Remote Loader Plugin

> Attackers can bypass Jenkins script security sandbox to execute arbitrary code via the Pipeline Remote Loader Plugin.

- **Severity:** Critical 9.9 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 May 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-v558-fhw2-v46w, RHBA-2019:2921

## What is CVE-2019-10328?

CVE-2019-10328 is a critical vulnerability in Jenkins Pipeline Remote Loader Plugin, published on 31 May 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Pipeline Remote Loader Plugin 1.4 and earlier provided a custom whitelist for script security that allowed attackers to invoke arbitrary methods, bypassing typical sandbox protection.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2019-10328?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:workflow-remote-loader. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:workflow-remote-loader` | Maven | All versions | 1.5 |
| `org.jenkins-ci.plugins:workflow-remote-loader` | Maven | All versions | 1.5 |
| `jenkins-2-plugins` | Red Hat:openshift:4.2::el7 | All versions | 0:4.2.1568997376-1.el7 |

Products: Jenkins Pipeline Remote Loader.

## How do I fix CVE-2019-10328?

Upgrade org.jenkins-ci.plugins:workflow-remote-loader to 1.5 or later.

## Is CVE-2019-10328 being exploited?

There is no known exploitation of CVE-2019-10328 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10328 and fix it if it is affected.

What it is: CVE-2019-10328 is a critical vulnerability in Jenkins Pipeline Remote Loader Plugin, published on 31 May 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10328 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:workflow-remote-loader (Maven): affected all versions; fixed in 1.5
- org.jenkins-ci.plugins:workflow-remote-loader (Maven): affected all versions; fixed in 1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10328/ (Markdown: https://insights.sbomify.com/CVE-2019-10328/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10328
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10328
- OSV: https://osv.dev/vulnerability/CVE-2019-10328

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10328/
Summaries are generated and may contain mistakes; the official description above is the record.
