# CVE-2019-10340: Jenkins Docker Plugin contains Cross-Site Request Forgery

> Attackers can trick users with read access into connecting to malicious URLs, potentially capturing stored Jenkins credentials.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Jul 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-m6gf-p26p-mx2w

## What is CVE-2019-10340?

CVE-2019-10340 is a high-severity vulnerability in Jenkins Docker Plugin, published on 11 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross-site request forgery vulnerability in Jenkins Docker Plugin 1.1.6 and earlier in DockerAPI.DescriptorImpl#doTestConnection allowed users with Overall/Read access to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2019-10340?

2 open source packages ship an affected version, including io.jenkins.docker:docker-plugin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.jenkins.docker:docker-plugin` | Maven | All versions | 1.1.7 |
| `io.jenkins.docker:docker-plugin` | Maven | All versions | 1.1.7 |

Products: Jenkins Docker.

## How do I fix CVE-2019-10340?

Upgrade io.jenkins.docker:docker-plugin to 1.1.7 or later.

## Is CVE-2019-10340 being exploited?

There is no known exploitation of CVE-2019-10340 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Docker Plugin

- [CVE-2019-10341](https://insights.sbomify.com/CVE-2019-10341/): Missing permission check in Jenkins Docker Plugin (medium 6.5)
- [CVE-2019-10342](https://insights.sbomify.com/CVE-2019-10342/): Missing permission check in Jenkins Docker Plugin (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10340 and fix it if it is affected.

What it is: CVE-2019-10340 is a high-severity vulnerability in Jenkins Docker Plugin, published on 11 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-10340 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.jenkins.docker:docker-plugin (Maven): affected all versions; fixed in 1.1.7
- io.jenkins.docker:docker-plugin (Maven): affected all versions; fixed in 1.1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10340/ (Markdown: https://insights.sbomify.com/CVE-2019-10340/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10340
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10340
- OSV: https://osv.dev/vulnerability/CVE-2019-10340

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10340/
Summaries are generated and may contain mistakes; the official description above is the record.
