{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:depgraph-view. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-10349 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:depgraph-view to 0.14 or later.","what":"CVE-2019-10349 is a medium-severity cross-site scripting vulnerability in Jenkins Dependency Graph Viewer Plugin, published on 11 Jul 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-10349 and fix it if it is affected.\n\nWhat it is: CVE-2019-10349 is a medium-severity cross-site scripting vulnerability in Jenkins Dependency Graph Viewer Plugin, published on 11 Jul 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-10349 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:depgraph-view (Maven): affected all versions; fixed in 0.14\n- org.jenkins-ci.plugins:depgraph-view (Maven): affected all versions; fixed in 0.14\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-10349/ (Markdown: https://insights.sbomify.com/CVE-2019-10349/index.md)","id":"CVE-2019-10349","markdown":"https://insights.sbomify.com/CVE-2019-10349/index.md","name":"CVE-2019-10349","record":{"aliases":["GHSA-4wj7-rh5h-5qmr"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins plugin","requires_auth":"low_privilege","summary":"Attackers with job configuration access can inject malicious scripts into Jenkins web pages via the Dependency Graph Viewer Plugin.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"dependency_graph_viewer","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A stored cross site scripting vulnerability in Jenkins Dependency Graph Viewer Plugin 0.13 and earlier allowed attackers able to configure jobs in Jenkins to inject arbitrary HTML and JavaScript in the plugin-provided web pages in Jenkins.","ecosystems":["Maven"],"exploits":{"exploitdb":1,"first_seen":"2019-07-12","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2019-07-12","kind":"exploitdb","ref":"47111","stars":null,"title":"Jenkins Dependency Graph View Plugin 0.13 - Persistent Cross-Site Scripting"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Jenkins Dependency Graph Viewer Plugin contains Cross-site Scripting","id":"CVE-2019-10349","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":2,"n_references":4,"next":{"headline":"Jenkins Port Allocator Plugin stores credentials in plain text","id":"CVE-2019-10350"},"packages":[{"ecosystem":"Maven","fixed":["0.14"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:depgraph-view","purl":null,"source":"GHSA-4wj7-rh5h-5qmr"},{"ecosystem":"Maven","fixed":["0.14"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:depgraph-view","purl":"pkg:maven/org.jenkins-ci.plugins/depgraph-view","source":"GHSA-4wj7-rh5h-5qmr"}],"prev":{"headline":"Jenkins Gogs Plugin stored credentials in plain text","id":"CVE-2019-10348"},"products":["Jenkins Dependency Graph Viewer Plugin"],"published":"2019-07-11","related":[{"cvss_score":4.3,"headline":"Jenkins Dependency Graph Viewer plugin vulnerable to missing permission checks","id":"CVE-2017-1000388","kev_date_added":null,"published":"2018-01-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"Attackers with job configuration access can inject malicious scripts into Jenkins web pages via the Dependency Graph Viewer Plugin.","url":"https://insights.sbomify.com/CVE-2019-10349/"}