{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:script-security. It affects 2 products.","exploited":"There is no known exploitation of CVE-2019-10355 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:script-security to 1.62 or later.","what":"CVE-2019-10355 is a high-severity code injection vulnerability in Redhat Openshift Container Platform, published on 31 Jul 2019. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-10355 and fix it if it is affected.\n\nWhat it is: CVE-2019-10355 is a high-severity code injection vulnerability in Redhat Openshift Container Platform, published on 31 Jul 2019. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-10355 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.62\n- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.62\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-10355/ (Markdown: https://insights.sbomify.com/CVE-2019-10355/index.md)","id":"CVE-2019-10355","markdown":"https://insights.sbomify.com/CVE-2019-10355/index.md","name":"CVE-2019-10355","record":{"aliases":["GHSA-p56j-x44h-g66j"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Script Security Plugin","requires_auth":"low_privilege","summary":"Attackers can bypass the sandbox to execute arbitrary code in Jenkins Script Security Plugin, requiring an upgrade to mitigate.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"script_security","vendor":"jenkins"},{"product":"openshift_container_platform","vendor":"redhat"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-704","name":"Incorrect Type Conversion or Cast"}],"description":"A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.61 and earlier related to the handling of type casts allowed attackers to execute arbitrary code in sandboxed scripts.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Incorrect Privilege Assignment in Jenkins Script Security Plugin","id":"CVE-2019-10355","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"redhat:openshift_container_platform","products":["redhat:openshift_container_platform"],"type":"code_injection","year":"2019"},"n_packages":2,"n_references":5,"next":{"headline":"Return of Pointer Value Outside of Expected Rang in Jenkins Script Security Plugin","id":"CVE-2019-10356"},"packages":[{"ecosystem":"Maven","fixed":["1.62"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:script-security","purl":null,"source":"GHSA-p56j-x44h-g66j"},{"ecosystem":"Maven","fixed":["1.62"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:script-security","purl":"pkg:maven/org.jenkins-ci.plugins/script-security","source":"GHSA-p56j-x44h-g66j"}],"prev":{"headline":"Missing Authorization in Jenkins","id":"CVE-2019-10354"},"products":["Jenkins Script Security Plugin"],"published":"2019-07-31","related":[{"cvss_score":9.9,"headline":"Jenkins Script Security Plugin Sandbox Bypass","id":"CVE-2019-1003029","kev_date_added":"2022-04-25","published":"2019-03-08"},{"cvss_score":9.9,"headline":"Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin","id":"CVE-2022-43401","kev_date_added":null,"published":"2022-10-19"},{"cvss_score":9.9,"headline":"Jenkins Script Security Plugin sandbox bypass vulnerability","id":"CVE-2022-43403","kev_date_added":null,"published":"2022-10-19"},{"cvss_score":9.9,"headline":"Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin","id":"CVE-2022-43404","kev_date_added":null,"published":"2022-10-19"},{"cvss_score":9.9,"headline":"Sandbox bypass vulnerability in Jenkins Script Security Plugin","id":"CVE-2020-2279","kev_date_added":null,"published":"2020-09-23"},{"cvss_score":9.9,"headline":"Improper Control of Generation of Code in Jenkins Script Security Plugin","id":"CVE-2019-10431","kev_date_added":null,"published":"2019-10-01"},{"cvss_score":9.8,"headline":"Jenkins Script Security Plugin has sandbox bypass vulnerability involving crafted constructor bodies","id":"CVE-2024-34144","kev_date_added":null,"published":"2024-05-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"Attackers can bypass the sandbox to execute arbitrary code in Jenkins Script Security Plugin, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2019-10355/"}