# CVE-2019-10358: Maven Integration Plugin did not mask sensitive values in module build logs

> Attackers can view sensitive build variables in logs because the Jenkins Maven Integration Plugin fails to apply log decorators to module builds.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jul 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-hr96-qfvm-52r6

## What is CVE-2019-10358?

CVE-2019-10358 is a medium-severity vulnerability in Jenkins Maven Integration Plugin, published on 31 Jul 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Maven Integration Plugin 3.3 and earlier did not apply build log decorators to module builds, potentially revealing sensitive build variables in the build log.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2019-10358?

2 open source packages ship an affected version, including org.jenkins-ci.main:maven-plugin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:maven-plugin` | Maven | All versions | 3.4 |
| `org.jenkins-ci.main:maven-plugin` | Maven | All versions | 3.4 |

Products: Jenkins Maven.

## How do I fix CVE-2019-10358?

Upgrade org.jenkins-ci.main:maven-plugin to 3.4 or later.

## Is CVE-2019-10358 being exploited?

There is no known exploitation of CVE-2019-10358 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Maven Integration Plugin

- [CVE-2019-16550](https://insights.sbomify.com/CVE-2019-16550/): Cross-site request forgery (CSRF) vulnerability in Jenkins Maven Release Plugin (high 8.8)
- [CVE-2019-16549](https://insights.sbomify.com/CVE-2019-16549/): Jenkins Maven Release Plug-in Plugin XXE vulnerability (high 8.1)
- [CVE-2017-1000397](https://insights.sbomify.com/CVE-2017-1000397/): MitM on Jenkins Maven Plugin (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10358 and fix it if it is affected.

What it is: CVE-2019-10358 is a medium-severity vulnerability in Jenkins Maven Integration Plugin, published on 31 Jul 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10358 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:maven-plugin (Maven): affected all versions; fixed in 3.4
- org.jenkins-ci.main:maven-plugin (Maven): affected all versions; fixed in 3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10358/ (Markdown: https://insights.sbomify.com/CVE-2019-10358/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10358
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10358
- OSV: https://osv.dev/vulnerability/CVE-2019-10358

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10358/
Summaries are generated and may contain mistakes; the official description above is the record.
